virtual screen too big in dual monitor setup, cannot set panning

I am using Xubuntu 16.04 on a Lenovo P50 laptop, connected to an external monitor via a hdmi(out)-dvi(in) cable.

I configured the external monitor (1920x1200) to be above the internal one (1920x1080) like so:

xrandr --output DP-1 --primary --mode 1920x1200 --pos 0x0 --output eDP-1 --mode 1920x1080 --below DP-1

The virtual screen size of the external monitor is always 1920x2280, so whenever I move the mouse down to the internal bottom monitor, the screen on the upper external one starts scrolling down as well - same issue as described in

The proposed solutions in that thread did not work for me though - I added the “–panning” option:

xrandr --output DP-1 --primary --mode 1920x1200 --panning 1920x1200 --pos 0x0 --output eDP-1 --mode 1920x1080 --below DP-1

but there is no effect - subsequent calls of “xrandr” still show

DP-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 546mm x 352mm panning 1920x2280+0+0
   1920x1200     59.95*+
eDP-1 connected 1920x1080+0+1200 344mm x 194mm
   1920x1080     60.02*+  59.93

This issue occurs with both nvidia-367 and nvidia-370 installed via The nouveau driver does not have the issue, but I get ugly artifacts when moving the mouse, so I don’t want to use that long term.

Any ideas what I could try to fix this?