Visual Studio 2012

Hi everybody…
There’s some release date for CUDA toolkit that support Visual Studio 2012?

It’s quite a bit that it’s available for developers.


Same issue here. I’m running W8, VS 2012 and CUDA 5.0 and nothing seems to be working correctly!

Bump for needing a good solution to developing in VS 2012 and CUDA 5… Or should I just uninstall VS 2012 and try and find 2010?

I’m in same situation… starting a new project and would much prefer using current generation
tools at the start of the project.

I followed the directions linked above:

and think I am up and running.


I actually just registered to ask this question. The above link worked for me. Thanks!

Yeah I followed that link and have not been successful :( What was the order of installation you followed from start to finish? Was it this:

  1. Install VS 2012
  2. Install CUDA 5.0
  3. Copy the files from the link above

Any other steps? Did you install NSight?

I installed cuda 5.0 before visual studio 2012. Did you make sure to edit the CUDA 5.0.props file and the CUDA 5.0.targets file? Also make sure you put them in the v110/BuildCustomizations folder, I made the mistake of putting them into the wrong folder the first time. Everything works for me, except there seems to be a minor issue with intellisense not recognizing a few CUDA specific data types.

Also, I can’t remember if the article mentioned this, but right click on the project name in the solution explorer select Build Customizations and check CUDA 5.0

That helped, but I still get the following errors:

Error 1 error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup C:\Users\mtr06bb\documents\visual studio 2012\Projects\CUDA_Test\CUDA_Test\MSVCRTD.lib(crtexe.obj) CUDA_Test
Error 2 error LNK1120: 1 unresolved externals C:\Users\mtr06bb\documents\visual studio 2012\Projects\CUDA_Test\Debug\CUDA_Test.exe CUDA_Test

This in addition to all the intellisense errors… Are there some library references that I have missed? All the files from the link above are present and accounted for in the correct directory…


Try and follow these steps. It worked for me but I couldnt get nsight to work. (check the QandA in the link)