Visual studio stops working when installing CUDA integration

I am on Windows 10 64 bits, and visual studio 2019. Cuda 11.1.

Just installing visual studio, this one goes perfectly.
When I install the integration with VS2019 that comes with the CUDA toolkit (https://developer.nvidia.com/cuda-downloads), the VS2019 starts to go very slow or directly the menu buttons (such as the create project) simply do not work. It seems as if VS2019 had a hard time connecting to the internet, because it is impossible to also add an extension.

In short, leaves it useless.

I’m not entirely sure if the CUDA is the cause but I feel my Visual Studio 2019 (and 2017) got slow after installing CUDA 11.1 toolkit too.
For example the response of VS menu bar, outline open/collapse button seems to get very worse than before.

Windows 10 1909
Visual Studio 2019 16.7.5

I tried to install VS2019 and CUDA 11.1 in a new Windows 10 installation in my laptop, and it still doesn’t work.

I think that there is a incompatibility with the newest version of VS2019.

Now I tried older versions of visual studio professional (TRIAL - 16.5.1) with latest cuda, and still not working. I’m confused now.

Should we go here?: