Vulkan on RTX 2060 Mobile

Greetings. First post, so I hope I’m doing this correctly.

So, having issues getting Vulkan to work on my Asus TUF FX505DV-PB74 that has 16GB RAM, Ryzen 3750H on FW v26.20.11030.2003, and RTX 2060 on FW v460.89. I’ve searched all over the nVidia forums, reddit, Google, and other forums for help resolving this issue, but to no avail. Contacting nVidia support recommended that I inquire here. Here are the symptoms. I’ve been trying to run Second Extinction on Steam, which requires Vulkan. It never assigns itself to a GPU in Task Manager and stays at 2MB used. Running GPU-Z and ensuring the GPU selected is the RTX, it never comes up with Vulkan as being supported. Having the Vulkan SDK installed (as one of the recommended fixes), I run vulkaninfo.exe and it lists the RTX as a GPU capable of presenting Vulkan, but launching vkcube.exe states that vkEnumeratePhysicalDevices reports zero accessible devices. Here are some things that I’ve tried.

  • Installed the Vulkan SDK (as aforementioned).
  • Disabled the Integrated Graphics and re-enabled them.
  • Disabled the Integrated Graphics.
  • Setting the RTX as the primary GPU in the nVidia Control Panel.
  • Setting the RTX as the primary GPU in the Windows Display Settings.

There may be some other things, but those are the ones that I’ve tried. Please help as this is getting extremely frustrating.

Thank you in advance.

Going to close this. I’ve figured out how to get it to work, albeit Vulkan never says that it’s available. Here’s the process I performed.

  1. Go to AMD’s website and download their auto-detect software for drivers.
  2. Install the software, including the Adrenaline software.
  3. Ensure graphics drivers are up to date.
  4. Once reboots are complete from AMD install, right-click on your desktop, go to Display Settings, scroll to the bottom and click Graphics Settings, then add the software you’re wanting to run and assign it to the dedicated GPU (High Performance).