W10 1809 Stability Issues - Driver update?

Hi and hello,

during our test drive, our W10 desktops with Update 1809 freeze when unlocking a locked VM. Not everytime, but very often.
Drivers used: NVIDIA-GRID-vSphere-6.5-410.92-410.91-412.16
Hardware: Tesla M60 - grid_m60-2b
Citrix_Virtual_Apps_and_Desktops_7_1808_2

I. Can anyone confirm this combination to run stable and what has to be done for that?

II. I see there is still no official support running W10 1809 and nVidia Grid at this time - when will it come?

Regards,
'doc

We have the same issue with m10 cards on esx 6.7u1 and grid 7.1.

Did you find a solution?

Hi

Try running a supported and validated version of vGPU driver and see if that resolves it. vGPU 8.0 is now available … https://docs.nvidia.com/grid/latest/index.html

Regards

Ben

Not yet.
Trying our luck with vGPU 8.0 drivers - just started testing. Reproducing can last days - the frequency it happens is not constant.

Can you provide more information about your environment?

So I reply to myself:

vGPU 8.0 did not make things better for us.
Seems to be an issue only when using Citrix - testing with RDP it does not seem to happen.

Seems to be an issue with display timeout and Citrix. Start disabling display timeout for the VMs and open a support case with Citrix to further investigate.

There is no policy setting to activate display timeouts we’d use - even if it had an effect to a Citrix session:

That does not seem to be the direction the problem comes from because the issue occurs like this:

  • VD is locked and the clock shown on the lock screen ist running on (so the VD is still up and running)
  • User comes to unlock, clicks with mouse or uses the keyboard to get to password input: VD crashes!
    -> as mentioned: not every time, but often.

Which component is responsible for the crash? dxgkrnl.sys?

Yes!

Probably caused by : dxgkrnl.sys ( dxgkrnl!memset+a4 )
km:av_invalid_dxgkrnl!memset

->

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced. This cannot be protected by try-except.
Typically the address is just plain bad or it is pointing at freed memory.
Arguments:
Arg1: ffffae8bfa693000, memory referenced.
Arg2: 0000000000000002, value 0 = read operation, 1 = write operation.
Arg3: fffff80260e12324, If non-zero, the instruction address which referenced the bad memory
address.
Arg4: 0000000000000002, (reserved)

Hi,

we have the same issue on Citrix Hypervisor 8.0

Regards
Korbinian

Do you have a Citrix case number we can point at when opening a case there ourselves?

Any news about this issue? I am experiencing the same problem and can reproduce it every time.
I changed the screensaver timeout to 5 minutes. After unlocking the VM crashes immediately.
The crashdump also says: "AV_INVALID_dxgkrnl!memset"

Details about our environment:
Citrix VDA 1903 (connected to Citrix Cloud)
Windows 10 1809
VMware vSphere 6.7 Update 2
NVIDIA GRID vGPU grid_m10-1b
NVIDIA Driver version 425.31

"C:\Program Files\Citrix\ICAService\NvFBCEnable.exe" -checkstatus gives me the result that FBC is disabled. After enabling FBC (-enable paramater) I cannot reproduce the issue anymore. I will do some further testing with this setting.

The Citrix documentation says this: https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/graphics/hdx-3d-pro/gpu-acceleration-desktop.html

[i]Install and upgrade NVIDIA drivers
The NVIDIA GRID API provides direct access to the frame buffer of the GPU, providing the fastest possible frame rate for a smooth and interactive user experience. If you install NVIDIA drivers before you install a VDA with HDX 3D Pro, NVIDIA GRID is enabled by default.

To enable NVIDIA GRID on a VM, disable Microsoft Basic Display Adapter from the Device Manager. Run the following command and then restart the VDA: NVFBCEnable.exe -enable -noreset

If you install NVIDIA drivers after you install a VDA with HDX 3D Pro, NVIDIA GRID is disabled. Enable NVIDIA GRID by using the NVFBCEnable tool provided by NVIDIA.

To disable NVIDIA GRID, run the following command and then restart the VDA: NVFBCEnable.exe -disable -noreset[/i]

Hi JP,

I don’t think this is relevant here. I cannot reproduce the issue no matter if I run NVFBC enabled or disabled. This is most likely a timing issue with ICA idle.
In addition Citrix changed the capture mode from NVFBC to DDAPI with 1809 and CVAD1903…

Hi

I can replicate this consistently with 1809 in my Lab (ESXi 6.7 U2 > Clean build of W10 1809 with all Windows Updates > CVAD 1906 > vGPU 8.0 with QvDWS). The moment I lock the VM, it crashes.

I’ve also tested the exact same configuration with W10 1903, and although vGPU 8.0 with 1903 is currently unsupported, this crashing issue does not occur.

You have a couple of choices … Either stay on 1803 and be supported without the issue, or if you really need to upgrade, move to 1903 currently unsupported but (from my tests) working and in preparation for the next vGPU release. I’ve tried 3D Apps on 1903 and had no issues with stability or performance and due to NVIDIA’s quick release cycle, it shouldn’t be too long before a vGPU upgrade comes along that will support 1903 …

Regards

Ben

With the above in mind, vGPU 9.0 has just been released, and this does have support for W10 1903 if you wanted to move to it.

I’ve tested W10 1809 with vGPU 9.0, and for me, the issue still remains. So my recommendation would be to skip W10 1809 and go to W10 1903.

Regards

Ben

Once again:
This is not a vGPU issue so independent from vGPU version. It can only be reproduced with Citrix stack involved and Citrix is already further investigating.
@Ben: Thanks for testing with 1903 as we now have at least a workaround until Citrix provides a fix for 1809.

regards
Simon

Thanks! I can confirm 1803 and 1903 are working fine without BSODs.

W10 1903 works for us, too - even with K1 and much older drivers…

Regards,
'doc

I am running W10 1809 and Driver 8.1.940. I still have freeze issues with multi monitors.
Going to W10 1903 is not option right now. Does anybody if there will be a updated driver?

regard,

Floris