We cannot show USD file converted from E57 file by View and some apps

Hi, I imported E57 file by Omniverse Create and saved by USD file.
Then I tried to open by Omniverse View, nothing is shown in 3D scene.
We can confirm files by Stage panel so it looks file itself was loaded.
Also if we try to open that USD file by 3ds MAX, 3ds MAX causes error.
And if we export to fbx or obj file from Omniverse Create, only small (32KB) file was created.

We are unclear this is because E57 file is but or because of settings.
But at least we can show by Omniverse Create.

  1. Environment

    • Omniverse Create ver.2021.3.8 because 2022.1.1 cannot open E57 because of error
      as reported by the forum.
    • Omniverse View : We tried both 2021.3.10 and 2022.1.1 but the same result.
    • PC : Azure Standard NC8as T4 v3 (8 vcpu, 56 GB MEM )
  2. When we import E57 file
    We got some warnings but the data is shown in 3D scene correctly.

  3. When we open USD file ( converted from E57 file ) by Omniverse Create
    We got some warnings but data is shown correctly.
    We confirmed by 2021.3.8 and 2022.1.1 and can show data by both version.

  4. When we open USD file ( converted form E57 file ) by Omniverse VIew
    We got some warnings include syntax error and nothing is shown in 3D scene.
    We confirmed by 2021.3.10 and 2022.1.0 and same results.

We changed parameter of “Flow” in Rendering Settings but same results.

  1. When we export E57 file to fbx or obj from Omniverse Create.
    There is no error. Only small file is created.
    File size is 32KB both fbx and obj file.

  2. E57 file
    Originally, this file is provided as PTS file and we converted to E57 by using
    the application CloudCompare.
    You can download original PTS file from below. ( file size : 437MB )
    https://3dcel.com/download/study03/ShibuyaUnderground.zip

  3. Converted USD file
    You can download converted USD file from below. ( 275MB )
    Sign in to your account

===

Masahiro Suzuoki

Hello @masahiro.suzuoki

I have some information that might be helpful to you.

I used the PTS file at your link with CloudCompare to generate my own USD file in Omniverse Create.

I see you said you edited the settings in the renderer - for high quality views you should certainly increase max blocks - I am on a laptop right now but I suggest 500,000 - 900,000 if possible.

then you can go back to your stage and select the flowPointCloud object. You can either turn on the checkbox for autoCellSize or edit it yourself (I selected 0.06), lower means higher resolution (make sure updateWhilePaused is checked - it should be by default)

Regarding your other comments:

I do not know if Omniverse View currently supports NVIDIA’s Flow extension, that is what is used to render UsdGeomPoints as voxels in the 2021 versions of Create. I see the option for Flow in the render settings, but I do not see it in the extensions tab.

So even though your usd file has all of the data in it, view won’t show it in the viewport because it isn’t the typical geometry the program expects, i.e. polygons.

I believe this is also the reason why your exports to .obj and .fbx are not providing valuable results, I am assuming the exporter parses the USD stage for meshes (vertices, indices, normals, UVs) and since our point cloud is not made of those things, nothing meaningful gets read out.

If you are just looking to have a high quality renderer for point clouds, editing the settings I mentioned above should provide very nice results. You can also increase the viewport resolution using the gear icon at the top left of the viewport.

If you are looking to convert to other filetypes for editing of point clouds, I would remain in CloudCompare until it is time to render, also there do exist programs that convert point clouds to meshes, but it is generally a bad idea with a point cloud of this size, you’d want to cut it into fractions.

I hope I could provide some insight to a fellow point cloud user. Have a good day!

-Matthew

Hello, @LMTraina99 ,

Thank you for the detail answer and it is very helpful for me.
I understood about the configuration regarding Flow and it looks we cannot show by
Omniverse View.
Unfortunately if I increase max blocks, Omniverse Create crashed because the resource exhausted
but it is because of my environment. I will try to adjust values.

Originally, pivot point of converted data is far from 3d model and it causes the start point of Cloud XR. So I try to modify pivot point by using 3ds MAX via USD file.
As you mentioned, what I want to do is editing the point clouds data.

I will investigate more and also thank you for your good suggestions!

===

Masahiro Suzuoki

1 Like