WebRTC Application

I have implemented a pipeline that outputs an rtsp stream, however I would ultimately like to be able to stream through WebRTC. I visited this link: Tegra Linux Driver

and tried out the code in WebRTC_r32.2.0_aarch64.tbz2 following the instructions in the README, however I am confused as to which IP address to use in this command:

./peerconnection_client --autoconnect --server <Server.IP>

I would have assumed it was localhost as I am running the server on the same device. But I get this error:
Unable to init server: Could not connect: Connection refused

I have also tried centricular’s web rtc demo code found here: GitHub - centricular/gstwebrtc-demos: Superseded by https://gitlab.freedesktop.org/gstreamer/gst-examples/-/tree/master/webrtc - Demo apps for using gstreamer's webrtc implementation with no luck.

**• Jeston Xavier
**• DeepStream 5.1

Hi,
Please you try this:
https://developer.nvidia.com/embedded/l4t/r32_release_v5.1/r32_release_v5.1/t210/webrtc_r32.5.1_aarch64.tbz2

If you can run DeepStream 5SDK 5.1, the release should be r32.5.1 instead of r32.2.0. You probably don’t download correct version.

Please also refer to ducment: Tegra Linux Driver

Hello, thank you kindly for the response. I tried the r32.5.1 file that you linked, however the same error occurs.

I have gone through the document, but I am stuck on this seemingly simple error.