WebRTC Server Error When Trying to access stream

Hi there,

I am trying to stream video from a USB 3 Camera connected to my Xavier using the WebRTC binary provided by Nvidia here (https://developer.nvidia.com/embedded/L4T/r32_Release_v4.3/t210ref_release_aarch64/WebRTC_R32.4.3_aarch64.tbz2).

I’ve run the peerconnection_server binary and am trying to verify that the stream is being served by trying to access it using gstreamer using: gst-launch-1.0 playbin uri=http://localhost:8888.

I get the following output from the terminal running peerconnection_server:

Server listening on port 8888
New connection…
Received an invalid request: /
Disconnecting socket
Total connected: 0

And the following output from the gstreamer terminal:

Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Got context from element ‘source’: gst.soup.session=context, session=(SoupSession)NULL, force=(boolean)false;
ERROR: from element /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source: Sorry
Additional debug info:
gstsouphttpsrc.c(1433): gst_soup_http_src_parse_status (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0/GstSoupHTTPSrc:source:
Sorry (500), URL: http://localhost:8888, Redirect to: (NULL)
ERROR: pipeline doesn’t want to preroll.
Setting pipeline to NULL …
Freeing pipeline …

I’ve also tried simply opening http://localhost:8888/ in a chrome browser and the same output is shown on the peerconnection_server terminal and the following text is shown in the browser: Sorry, not yet implemented.

The same issue persists even when I tried to access the stream using VLC.

The issue is still there when I run peerconnection_client. What is this binary even for? I was expecting it to open the stream and display the camera output, but it doesn’t do that.

I’ve tried searching for documentation on the binaries provided in this package but all I’ve found is this (https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%2520Linux%2520Driver%2520Package%2520Development%2520Guide%2Fhardware_acceleration_in_webrtc.html) and it doesn’t provide much detail on the usage of the binaries or what they do.

Could you please help me with this issue?

Thank you,
Farbod

P.S. How do I create 2 seperate streams when I have 2 USB 3 Cameras plugged in? Thanks

Please refer to
https://devtalk.nvidia.com/default/topic/1018689/jetson-tx2/vlc-playing-gstreamer-flow/post/5187270/#5187270
https://devtalk.nvidia.com/default/topic/1014789/jetson-tx1/-the-cpu-usage-cannot-down-use-cuda-decode-/post/5188538/#5188538

I tried again with the ./peerconnection_clien binary and it works now for about 5 seconds and then crashes.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Crash while open two steaming together?
Could you clarify with videotestsrc?