WebRTC streaming on Jetson Xavier NX

Hi

I have a jetson Xavier connected to a Camera. I am trying to stream video via webRTC. I am using the NVIDIA Hardware Acceleration in the WebRTC Framework.

Following are the scenarios I have tried.

  1. Run the peerconnection server in one xavier board. (say X1)
  2. Run video_loopback in another xavier (X2)
  3. Run peerconnection client c1 in X2.
  4. Run peerconnection client c2 in another xavier X3.

Whenever I try to access client c1 from c2, I get the following error.

Fatal error in: …/…/media/engine/adm_helpers.cc, line 39

last system error: 88

Check failed: 0 == adm->Init() (0 vs. -1)

Failed to initialize the ADM.Aborted (core dumped)

I got to know that this is due to the audio module not getting initialised.

(I also tried running the server and 2 clients in a single Jetson Xavier, but still I got the same error on trying to access clients.)

  1. We have however removed the pulse audio daemon due to some issues in the past and would like to test the current webRTC stream without audio. Is there any way to do this?

  2. How can I get the source code for the WebRTC framework?

  3. Is there any way to test WebRTC streaming from jetson Xavier on a third-party server?

Thank you

Hi,
Please refer to document:
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hardware_acceleration_in_webrtc.html
It is the case verified in each release. In the package, some files are in source code and some are in binary. The source code for the binary files is not public.