What is the pixel format of the raw video recorded by driveworks?

recorder-qt records camera stream into a raw video. I want to convert video using ffmpeg but I don’t know what pixel format to use. Anybody knows?

Dear jiaweih,

You may compile ffmpeg from sources (compile with --enable-pic for position independent code) on your DPX2. Then, you may convert from raw to x264, and back. That’s how I did. Thanks.
https://superuser.com/questions/322354/using-ffmpeg-to-encode-a-raw-video-to-h-264-format

Hi, SteveNV.

Thanks for your advice. But as your link suggests, “if you have a raw YUV file, you need to tell ffmpeg which pixel format, which size, etc”. For example, whether it is yuv420p or yuv422, etc. Without knowing the pixel format in the raw video, ffmpeg is unable to decode.

I don’t need to do the raw -> x264 conversion on DPX2. I can do it on my host machine. But the raw format is what I’m looking for.

Hi,

I am also having the same problem. I recorded raw footage with recorder-qt and I ran the command as suggested in the forum:
ffmpeg -f rawvideo -pix_fmt yuv420p -s:v 1920x1208 -r 30 -i video.raw -c:v libx264 output.mp4

In the end of conversion ffmpeg throws an error: Invalid buffer size packet size < expected frame size. I think the pixel format is not correct. I also tried with yuv422p and yuv444p. I recorded with a 2M Sekonix camera that is shipped with DPX2 (http://sekolab.com/products/camera/)

Any suggestion?

BOLEMAX,

I can’t answer your question direclty, but I do have a method to extract images from the raw video, and then you can reassemble it to any video format you want. To extract images, you can use Sherlock is a Driveworks tool located at /usr/local/driveworks/apps/sherlock/bin/sherlock on the Host PC.

Usage:
–start_sec arg
–interval_sec arg
–duration_sec arg
–start_frame arg
–interval_frame arg
–duration_frame arg
–output_folder arg the output folder of the , will try to create when not exist
–jpg_prefix arg
–jpg_suffix arg

Example:
/usr/local/driveworks/apps/sherlock/bin/sherlock -T XXX.raw --output_folder ./img

Hi jiaweih,

Thank you for your answer. This is exactly what I actually needed.

Where is the sherlock tool in driveworks 0.6?