Which CUDA version will work with driver 390.77???

I’m using four GTX Titan Xp with driver version 390.77. Further I installed CUDA version 9.2 on Ubuntu 16 and realized it doesn’t work with the drivers.
I don’t want to use a different driver for the GPUs. I am rather looking for the appropriate CUDA version to use. Any recommendations?
Thanks a lot for any suggestions!

According to the table in the CUDA release notes, driver 390.77 should have support for CUDA 9.1, but does not support CUDA 9.2.

https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html