Which version of CUDA for Xcode9?

Have CUDA 9? supported for Xcode 8.3.3 or Xcode9 ? And then, which version CUDA should I download?

The supported Xcode versions are listed in the mac install guide for each CUDA version.

Here it is for CUDA 8:

http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html#system-requirements

the install guide for CUDA 9RC indicates the following:

Table 1 Mac Operating System Support in CUDA 9.0
Toolchain
Mac OSX Version
(native x86_64)
Xcode Apple LLVM 10.12
8.3.1 8.1.0 YES
Before installing the CUDA Toolkit, you should read the Release Notes, as they provide
important details on installation and software functionality.

So, support for Xcode 8.3.1