Why does the cube need to be bounced twice to break in the blast simulation



As this video shows, when I tried to simulate the blast, the cube cannot break when it hit the ground, but break in midair, why is that?
blastsim01.usd (1.3 MB)

Hi @Wayne1407, could you attach the USD file itself? I haven’t seen it behave that way before, but would be happy to take a look. This happens every time you open the file? It looks like it is breaking when it hits the ground, but the pieces are created back where the cube started, then they fall again. Is the cube owned by the current stage, or did you import a reference to another file?

blastsim01.usd (1.3 MB)
Hi, EricArnold, here is the .usd file that used in that video, and the cube is owned by the current stage. Is it caused by the the RTX2080ti not meeting the calculation requirements? The image below is the Profiler interface.

Thanks for sending your file, I’ll check it out and let you know what I find. The 2080Ti shouldn’t be a problem, that is what I have in one of my machines, and it works just fine.

Hmm… so far I’ve been unable to repro your issue. You are on ver 0.9.14 of the Blast extension, right? Can you send me a screen grab of the Help → About dialog so I can make sure I’m on the exact same version of Kit as you?

Is there anything else you can think that you might be doing differently? I just load Create, load your scene, and press play. The box drops and breaks apart when it hits the ground. Pieces show up where they should, they don’t teleport back to the starting location.


Hi!
Thank you for your reply, the version of Blast extension is 0.9.14, the same as yours. I also found that when I loaded the blast examples-Combine in the window->simulation->Demo Scenes, it has the same problem.

Here is it simulation movie capture, and is the problem about graphics memory?

Hi, there is another question about using the Blast extension when I checking the blast examples. How to add the unbreakable bonds within two meshes? I noticed that the cube which has unbreakable bonds with the wall has different Contact Threshold, with “value from selection” in parentheses, and the other cubes that has breakable bonds with the wall is “value to be applied” in ( ). Also with the Default Bond Strength, one cube may have “inherited” following it, one may don’t have. I don’t know how to set it, for I’m so new to using omniverse.
Any advice would be appreciated!
Cheers!

I’ll have to keep digging to figure out why you are getting odd behavior from fracture. Does the “Fracture” demo have the same issue?

For bonds, the blue cube has a different label because it doesn’t have bonds with the wall. It will fall if you press play. The red cube has unbreakable bonds with the wall, the green cube has breakable bonds with the wall.

Whether they are breakable or not is controlled by the checkbox next to “Recalculate Attachment” a little farther down in the panel. Checking that box will make the bonds between the destructible and world geometry unbreakable, unchecking it will set the bond strength to be the area between them.

Hope that answers your question there. I’ll let you know if I can find any answers to the issue you are having with simulating fracture.

“Value to Be Applied” means that the selected prim doesn’t have it set. We should come up with a clearer way to message that. Since some of the UI values can be set before prims are combined/fractured and are used as initial values, we wanted to call them out differently than when we pull values from the selection. For the green and red cubes, if you change the value while they are selected, it will be stored on the prim. Changing it while the blue cube is selected won’t have any lasting effect unless you then press the “Recalculate Attachment” button, then the current UI value is used.

Also, in case it wasn’t clear, the “Max Contact Impulse” is only used for destructible prims that are attached to static world geometry. That’s why the blue cube doesn’t have a value set on it. We tried to describe that in the tool tip if you hover over the “Max Contact Impulse” label.

Thank you for your detailed answer! I have learn a lot about it, I think omniverse can totally meet my needs!

Speaking of the question of Blast Demo, truly there is a problem about “Fracture” demo, the video below is the simulation of it, thank you again for your careful answer!

Hi @Wayne1407,

I work with Eric on the omni.blast extension. I’ve also tried to reproduce the behaviors you’re seeing, without success. I’m not sure what we can do to address these behaviors you’re seeing, except to suggest that you update the extension as soon as a new version becomes available. We are actively updating blast and the kit extension, and new versions should be rolling out with upcoming kit/create updates.

I’m sorry I don’t have a better answer for you. I’m glad to hear you’re happy with omniverse so far, and hopefully it will better meet your needs as we improve it.

Bryan Galdrikian

Thank you for your reply!
I have change another computer with two RTX2080ti and it can work well, but I am not sure it is based on multi-GPUs, is these information in the red frame show that simulation is work under two GPUs? Will I make some settings elsewhere, because when it comes to larger project, the Create or Isaac-sim may close itself.

It looks like both of your cards are being used. If you are having problems with large scenes you should start a new thread for that. I don’t have a machine with multiple GPUs, so I’m afraid I won’t be much help there.

1 Like