Windows 10 Update broke Optix 6.0 on my machine

Just a heads up, yesterday, Optix 6 was working fine here. Today the call to rtDeviceGetDeviceCount() returns 0 in my own projects and in all the Optix 6.0 samples. Optix 5.1 still works fine.

When I checked to see what changed on my machine I discovered a Windows 10 update early this morning and when I rolled it back, Optix 6.0 began working again

Windows 10 Home
Geforce GTX 1060 driver (3/1/2019)
Cuda 10.1

Yikes! That’s a tad scary. Thank you for the report; we’ll investigate a little.

Are you on a 64 bit version of Windows? Are you in a place where you could accept the Windows update and try it against the most recent driver? If anyone else here with Win 10 Home tries the update against a 430 or higher driver, we’d love to hear the results.


Yes, me.

As for today my Windows (home and pro, both 64-bit) seems updated and the system itself does not seem to be a problem.

But… I was chasing bugs on my side for a week and in the end I realized it is the driver. OptiX behavior became unbearable with the last update to 430.86, but the same issue happened with earlier versions, just less likely.

Reverting to 419.67 removes all problems.

I am also developing in Linux, and I have the same bad results with 430. Later today I’ll switch to Linux and will try old drivers there.

For me the launch function never returns in some scenes. My workflow is: series of raytracing accumulation launches, followed by few 2D postprocessing and denoising launches and a final conversion to colors. Each such frame is displayed in a loop. The point is that problem can appear in any launch performing any operation, but only in the first 1-2 frames. This suggests a problem with some initialization. Couts put between launches can hide the problem, I guess it allows some time to finish something that is not synchronized well.

There are no exceptions from shaders, and no timeouts.

I did not manage to reproduce the problem in SDK samples (tried to loop launches, but everything works fine).

I tried this on GTX 1050 and GTX 1060.

Happy to provide more details if needed and get rid of this problem ASAP, since I am encouraging my users to keep drivers updated…


That sounds like rtDeviceGetDeviceCount() is working with latest Win10 home updates and both the 419 and 430 drivers, correct?

As for your hangs @robert_sulej, since the SDK samples don’t reproduce the problem, are you able to put together and share a minimal reproducer with us?


Right, rtDeviceGetDeviceCount() is working in all cases.

I just downgraded Linux (Ubuntu 18.04) divers from 430 to 418 - all problems gone!

I can cut a “minimal” reproducer from the full stack I have. It will be still a large project since I would keep denoiser binaries in their places. Something like would work to share it? I can point you to the lines where to play with the code and hope that you can get the same effect - it all looks like timing issues and different scenes hang in Linux and Windows…


Yes, I’m using 64 bit Windows 10. Today I updated to driver 430.86 and installed the latest Windows 10 update(1903) and Optix 6.0 is working again. Whew :)

Oh, whew, agreed! Thanks for the update, that’s great to know it was only temporary.

Today the update 1903 was so kind to bring back also the driver 430.86 for me and I could verify that my issue is still present (and installing 419 still helps). Maybe this is another issue than Bird33 had, should I open a new thread?

I have a not-so-minimal setup, hopefully relatively clear to explain and compile. I can share it (what would be your prefered way to send it?). If you’d like a quick way to test if you want to dive into this issue, there is also a Python package based on that code, with some examples that are not working with 430 (e.g. #1, #2 for me), quite simple to install in Windows. Just let me know.