Windows surround problem - gaps between windows

Tried to find a solution to the problem myself and surprisingly not a lot of folks even bothered with it.
It means that it’s either quirk of my own windows, or not a lot of people use surround in the first place. Not sure.

But anyway, here is the screenshot:

…and I marked there a gaps between windows that appears only on surround display, if I try to maximize them.
For comparison top three monitors are not “surrounded”, and as you can see windows there maximize just fine, without gaps between them.

How to get rid of those gaps between windows on surround displays?

Hi @Xeizzeth ! Welcome back to the dev forums!

I assume you are familiar with our Surround FAQ?

Is it possible that you changed some Bezel setting in the control panel?

Can you provide some more detail on your setup?

  • Exact details of your graphics card(s), which GPU, brand, number of outputs
  • Details of the monitors used, including which connection is in use (DVI, HDMI, DP)
  • NVIDIA driver version
  • Windows version

This could very well be related to monitor timings or similar mismatches between the displays. With a bit more information we can hopefully dig a bit deeper.

Thanks!

Greetings @MarkusHoHo

Yes, I am familiar with it, and just now read it to it’s entirety again.

I did not touch bezel settings.

Two vcards:
Palit 3060ti with three displayports and single hdmi port.
Palit 1050ti with one DP, one HDMI, one (currently unused) DVI port.

All six monitors are Philips 328E1CA 32" Curved Monitor: Curved LCD monitor with Ultra Wide-Color 328E1CA/01 | Philips

Three bottom ones are all connected to three DP ports of 3060ti.
Central top one is connected to HDMI of 3060TI.
Top left one is connected to DP of 1050ti.
Top right one is connected to HDMI of 1050ti.

I am currently on linux, but I always use latest drivers and always update through nvidia experience. So it’s safe to say that it’s latest currently available drivers.

Windows 10, latest updates.

I don’t think so, actually, because I previously used Samsung U32R590CWI 4k monitors, more precisely those ones: 32" UR59C Curved 4K UHD Monitor Monitors - LU32R590CWNXZA | Samsung US
…and the problem was present there as well.


I also can just make a video of the problem, if it is necessary.

Hi there,

Ok, took a while to get my head around your setup.

What resolution do you use for your monitors? One 3060Ti only supports a maximum combined resolution of 7680x4320, If you drive all your monitors (regardless of Surround or not) at anything higher than 1080p you will run into issues.

What happens if you disable the non-surround output from the 3060TI and make the 1050TI outputs your primary displays?

To be honest, your setup is way beyond the original spec on how to build GeForce based Surround systems.

For surrounded displays the resolution is 11520x2160@60Hz.
For the rest three monitors it’s standard 3840x2160@60Hz.

This problem with gaps also existed on a 1050ti, which also supports 7680x4320 as top resolution, where I put three monitors at surround mode at 5760x1080 resolution.
So I bet it’s not the problem of the resolution per se.

And just as an experiment, I will put all my monitors at 1080 vertical resolution to see if it will make any difference:

And just as I thought - the gaps are still present:

I cut the image, and showing only left and central monitors of the surround solution. But I think it’s visible that I put the resolution of surround displays at 5760x1080, and other monitors at just 1920x1080, and windows are maxed out (I hope the icon next to the X button is still visible, despite the fact that forum engine resized the image, and it is showing that the windows are maximized), and still the gaps between the windows, or between the edges of the screens are also visible (well, if we discount the left monitor, and three top ones since I cut them out).


Nothing. The gaps still will be present:


I actually read your request wrong, and disregarded the words you said about making 1050ti’s monitor a primary one, and now I made it. The DP monitor of 1050ti’s is the primary one now, and the problem still stands:


And not only it still stands, but it somehow got even worse. Note the gap between nvidia control panel window and the browser window. Both windows are maxed out.

And I’ll make the nvidia control panel more visible, because I don’t think it’s visible enough in the previous screenshot:


And I’ll show you the bezel settings, just in case you’ll ask for them:

And I think the problem is not actually the surround, but maybe windows itself, or rather it’s windows (actual GUI windows) manager.

1 Like

Of course that is very well possible, although I am reluctant to blame others. Window management has changed quite a bit since NVIDIA Surround was first brought to “life”. And this feature is not under active development but only supported as is. The multi-display spanning support nowadays concentrates on professional settings using NVIDIA MOSAIC.

Out of curiosity I tried Surround on my 3060TI, three monitor setup as well. My setup is very heterogeneous with three different displays, 2 WQHD one 4k, and I could observe the same effect when using normal desktop. The last time I used Surround, maybe two or three years ago, desktop app windows were maximized across all surround screens. Now Windows will only maximize (with free space around it) on one single window.

But when I started a game that supports this big wide screen resolution, it showed fullscreen without any issues.

That does indeed lead me to the conclusion that the Microsoft Window Manager does not play ball with the Surround setup. As a side note, I was unable to get it to work at all on Windows 11.

I will forward this information to our engineers, but I cannot make any promises that this will be addressed, I am afraid.

Thanks!

Yes, this “free space around it” is exactly the thing I am addressing here.

Thank you for taking a note. I hope it will be resolved.