X Server 1.17.2 hanged after installed 381.22 to RHEL 7.3 for GeForce GT 720M

It would be much appreciated if anyone could help me solve this problem.

I used to follow the below instruction to install 381.22 to RHEL 7.3:

  1. Blacklist Nouveau
  2. Rebuild Grub
  3. Install NVIDIA driver
  4. Rebuild initramfs

Ref: https://access.redhat.com/solutions/1155663

That worked on one of my PC, however, not for another, with the hardware configuration as below:
https://www.cybernetman.com/en/24-inch-medical-grade-all-in-one-pc

This PC has GeForce GT 720M. The installation of 381.22 was complete. No error was prompted. Yet, I noticed one different thing: the installer did not ask me whether to use NVIDIA X Config (later I did try to manually run “nvidia-xconfig”, but the problem still persisted). Then X Server (v1.17.2) could not start. The screen showed (see attacheded photo):

Oh no! Something has gone wrong.
A problem has occurred and the system can’t recover.
Please log out and try again.
I could do nothing but to switch to another TTY.

I consulted Red Hat technical team. They studied for many days but still had no idea.

Enabled GDM debug, and from the log file “var/log/gdm/:0-greeter.log” these were found:

gnome-session-is-accelerated: No hardware 3D support.
Xlib: extension "GLX" missing on display ":0".
gnome-session-check-accelerated: Helper exited with code 256

** (process:2361): WARNING **: software acceleration check failed: Child process exited with code 1

Here I also attach the nvidia-bug-report.

Any advice is much appreciated! Thanks in advance!
nvidia-bug-report.log.gz (83.3 KB)

This is laptop hardware, i.e. an Optimus system. You will have to configure it to use PRIME if you want to use the Nvidia gpu.
http://us.download.nvidia.com/XFree86/Linux-x86/375.10/README/randr14.html
https://wiki.archlinux.org/index.php/NVIDIA_Optimus
Otherwise, uninstall nvidia drivers and use intel gpu.

Dear generix,

Thanks for pointing this out! Unfortunately, Red Hat does not support Optimus system. I tried Suse, and it worked. Seems I have no choice but to give up Red Hat.

Thank you so much.