Xavier AGX (4.9.140-tegra) reboots with wrong date "Sat Jan 1 09:00"

Hi,
can some one share on how to get the reboot date correct in Xavier AGX. The following are the observations :
$ date
Sun Dec 6 12:23:26 +08 2020

$ last reboot
reboot system boot 4.9.140-tegra Sat Jan 1 09:00 still running

$ last -x | grep shutdown | less
shutdown system down 4.9.140-tegra Sat Dec 5 18:40 - 09:00 (-7644+09:39)

$ last -x | grep reboot | less
reboot system boot 4.9.140-tegra Sat Jan 1 09:00 still running


Thanks.

Does the Xavier have internet access? If so, then it should be able to update from ntp. Assuming you have internet access, what do you see from “timedatectl”?

It should straighten out after few gracefull shutdowns, as it seems to me
ref: https://unix.stackexchange.com/questions/411290/debian-two-entries-in-last-reboot-in-still-running
ref: https://unix.stackexchange.com/questions/410734/what-is-the-purpose-of-the-10th-column-of-the-last-commands-output
ref: https://superuser.com/questions/1199551/interpreting-last-reboot-output
ref: https://www.cyberciti.biz/tips/linux-last-reboot-time-and-date-find-out.html
Moreover, you may also use

uptime
last reboot -F
sudo su
 hwclock -r

etc
However, I can see that the date is returned in a correct way. Also I pressume that ntp is enabled as per default.