Xavier AGX power-on system failed to boot

After the xavier AGX module is powered on, there is a certain probability that the system will not be able to enter the system normally. The final HDMI display information and Debug serial port information are shown in the attached file. Please help analyze the reasons and solutions. Thanks
Hardware Platform:DRIVE AGX Xavier 32GB
Host Machine Version:Example: native Ubuntu 18.04
Jetpack Version:4.2
Debug UART information.txt (37.2 KB)

Hi,
Does the issue happen on Xavier default board? If yes, we can try to reproduce the issue. Please also share release version( $ head -1 /etc/nv_tegra_release )

The xavier carrier board is our own design,and the release version information is"R32(release),REVISION:2.1,GCID:16294929,BOARD:t186ref,EABI :aarch64,DATE:Tue Aug 13 04:45:36 UTC 2019"

During the problem test, another error phenomenon was recorded. See the attachment for the debugging serial port information.
Debug UART information 2.txt (81.2 KB)

[    8.736001] Root device found: mmcblk0p1
[    8.738819] Found dev node: /dev/mmcblk0p1
[    8.851860] EXT4-fs (mmcblk0p1): 15 orphan inodes deleted
[    8.853302] EXT4-fs (mmcblk0p1): recovery complete
[    8.865272] EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts: (null)
[    8.867851] Rootfs mounted over mmcblk0p1
...
Press Enter for maintenance

The filesystem itself has received a number of errors exceeding the ability of the journal to recover. I am guessing that a number of bad shutdowns were required due to development and testing, but there is a chance you will need to flash again to get a working ext4 filesystem. Technically you may be able to recover the filesystem, but some of the content would be missing. Regardless of what the current issue is I would expect the currently corrupt filesystem to get in the way.

You can still clone and have the clone available. Clones can also have ext4 recovery when covered by loopback, and the recovered clone could be used for flash. It takes some time and effort to clone, but it is worthwhile.

HI,

Please finish the first boot configuration with oem-config and try to operate the system through serial console.

https://elinux.org/Jetson/General_debug

We need your help to dump log

  1. /var/log/Xorg.0.log
  2. /var/log/syslog
  3. dmesg