Jetson AGX Xavier can't enter the desktop

When AGX Xavier is power-on, there is a certain probability that it cannot enter the desktop. By viewing the debug serial port log, it will stop at the same point when it fails to start normally.

[ 0.000000] Boot CPU: AArch64 Processor [4e0f0040]
[ 0.000000] OF: fdt:memory scan node memory, reg size 48,
[ 0.000000] OF: fdt: - 80000000 , 2c000000
[ 0.000000] OF: fdt: - ac200000 , 44600000
[ 0.000000] OF: fdt: - 100000000 , 780000000
[ 0.000000] earlycon: tegra_comb_uart0 at MMIO32 0x000000000c168000 (options ‘’)
[ 0.000000] bootconsole [tegra_comb_uart0] enabled
[ 0.000000] Found tegra_fbmem: 00800000@a069b000
[ 0.000000] Found lut_mem: 00002008@a0695000

[ 1.953721] tegra-xudc-new 3550000.xudc: extcon_get_extcon_dev_by_cable failed -19
WARNING: pll_d3 has no dyn ramp

Attached is the debugging information for normal startup and abnormal startup. Please help analyze the possible causes of abnormal startup. Thanks.

failed.txt (26.2 KB)
pass.txt (28.3 KB)

The module carrier board is designed by us.

hello zhoujunquan,

did you include quiet into the APPEND? please exclude that from /boot/extlinux/extlinux.conf to gather detail logs.

There is no quiet mode. From the log information, both normal startup and abnormal startup will print this information, but the startup will stop here if the startup is abnormal; when the startup is normal, the information will continue to be printed.

hello zhoujunquan,

this should failed by tegra_xudc_driver, could you please remove all peripherals for verification.
please also review UPHY Lane Assignment since it may be USB PHY related probing failure.
thanks

The test found that the problem is related to the module PCIE C5 port expansion M.2 SSD. Remove the 4*Lan M.2 SSD connected to the C5 port, and the system can start normally.

hello zhoujunquan,

please check the documentation to review PCIe controller configurations.
thanks