XAVIER Industrial RTC current consumption high

Hi , We need your support on AGXi RTC CURRENT CONSUMPTION problem.

We use Xavier Industrial Module on our own designed carrier board. We use a 0.1F supercap for VDD-RTC. After power on, the capacitor is charged to 3.5V. Then if we unplug the power supply, the voltage of the supercap will decrease quickly. It takes about 10 minutes for the voltage to drop from 3.5V to 1.6V. We calculate the rtc current and it is about 330uA.

We also test the current consumption on Nvidia DevKit. After the capacitor has been charged to 3.5V. If we unpluged the power supply, the voltage of the supercap will drop from 3.5V to 1.6V in 8 minutes.

According to other discussions on this forum, the current should be 2uA.Is there anything can be done to reduce the current consumption for AGX industral? What is the rtc current for AGXi?
Thanks!

Please refer to this topic: How to configure RTC supercapacitor charge current? And how long RTC can work without power with fully charged 0.07F capacitor?

Also you can search “RTC current” in forum for more info.

Thanks for your quickly reply.
The problem we face is that the discharge current of RTC is to high(330uA). I have explored the relayted topics on this forum. Several mention that the normal RTC current consumption is 2uA. Most of these are AGX, not AGXi. Only one topic mentions AGXi draws current about 0.4mA which seems have the same proble with us AGX Industrial not booting at negative temperatures - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums .

Have you futher details about rtc current consumption of AGXi? What setting can we make to reduce the discharge current?

Thanks!

The discharge current is still large, 330uA. Does anyone have the same proble? Could someone give some helps? Thanks!

We are checking internally, it might be reasonable on AGXi. Will update result once available.

Thanks Trumany. We may need to find other solutions.

Hi, can you help double confirm if the power drawn is when nothing is connected but only a bbatt or the system is fully powered and bbatt is also there and drawing 0.4mA?

I just take a measurement as your requirement. We designed a series 120 R resistor between the VCC-RTC and the supercap. When poweroff and nothing is connected. The voltage of the resistor is about 0.058V, so the current is around 0.4mA. If anything is still needed, please let me know.

Is it in power off status with power supply plug in still?

We just switched off the Switch Power Supply。 The connector which connects the power supply and our carrier board is still plugged in, But when we take test on Nvidia DevKit, we unplugged the DC JACK . The battary voltage also decreased quickly. It seems that plug or unplug is not a key role. Hope this is helpful to you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.