Xavier NX Display Port output failed

Hi team,

I have a customized carrier board for Xavier NX. The board used TI solution(TPS65987 + HD3SS460) to make DP Alt mode over TypeC.
When I plug a TypeC monitor into the customized carrier board TypeC receptacle. There is no display signals output. In the other words, the monitor doesn’t light up.
I’ve tried to use Xavier NX 8GB and 16GB, but both failed.
I also tried to use nano and TX2 NX boards on my customized carrier board. It succeeded.

When using Xavier NX SOM, the UART output log is below when plugging. I measured the HPD pin with a multimeter, it’s High after plug.

[ 114.657749] tegradc 15210000.display: tegra_dc_reserve_common_channel: DC 1 timed out waiting for the COMMON channel
[ 114.657789] tegradc 15210000.display: tegra_dp_irq_evt_worker: DC 1 reserve failed during DP IRQ

Looking forward to your response and suggestion. Thanks!

Full dmesg, dts file which converted back from dtb. Please attach them first.

Hi Wayne,

Attached the dmesg log. The som used is Xavier NX 16GB. Please take a look. Thanks.
How to get dts file?
dmesg.txt (97.7 KB)

Use dtc tool to convert your finalized dtb back to dts.

Hi Wayne, is there a guide for reference. Many thanks!

From the dmesg log, looks like the dp link training failed. When I use TX2 NX and nano board, the dp link training passed.

You can just search dtc (device tree compiler) on the Internet… this is not something created by NV.

Also, you can just compare the sor and nvdisplay node between your NX and TX2-NX.

The driver in use on these two platforms are totally the same.

Let me try, thanks.
Actually, I used the OS and file system download from NV. Nothing changed.
L4T Archive | NVIDIA Developer

Then you should change it according to your schematic.

NX and TX2-NX also used the same carrier board, the schematic should be correct.
Is there something parameters I can tune for dp link training?

Hi Wayne, Attached the NX and TX2-NX dts file converted from /boot/dtb/*.dtb.
Please help to review. Thanks!
The schematic used DP0 nets.

xavier_nx.dts (253.1 KB)
og_jetpack_4.6.dts (239.2 KB)

The TX2-NX OS is L4T 32.7.1, it works well.
The Xavier-NX OS is L4T 34.1.1, it failed. Also, degraded one Xavier-NX-8GB to L4T 32.7.1, still failed.

the edid can be read out. but the monitor doesn’t light up.
image

Please use this monitor on NX devkit and see if it can pass the link training.

If it can, then please review your schematic and the dts to see if anything not match.

this monitor on NX devkit is good.
it’s strange that TX2-NX and Nano SOM can work on our customized board, but Xavier NX can’t.

That has nothing strange to me… Lots of such case has been seen.

When using TX2-NX, the DP 4 lanes work fine. So it should not be a schematic issue. I’ve no finding on the dts files. Do you have any findings or other suggestions?

Please stop using TX2-NX to prove something. This may not matter.

If the default device tree in NX does not match your board, then it won’t work either. It has nothing to do with TX2-NX.

You should compare devkit case and your carrier board. Forget about TX2-NX or Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.