Xavier ROM Flashed onto Jetson Nano

Hi,
I was trying a flash my Jetson Nano (ADLINK DLAP 301 Nano) with the latest BSP. I downloaded the wrong BSP and now the SOC ID is shown as 0x19 instead of 0x21 and even in SDK manager the board is showing the connected device as Jetson Xavier NX and not Jetson Nano.

When I put the device in recovery mode, the device ID is also shown as Bus 005 Device 011: ID 0955:7e19 NVidia Corp

When I try flashing the device using flash.sh from NVIDIA (following Tegra Linux Driver ) is get the error Error: The Actual SoC ID(0x19) mismatches intended jetson-nano-emmc SoC ID(0x21)

When I am using the supplied ADLINK flash utility, it is always showing me the BOOTROM COMMUNICATION FAILED Error

Can someone guide me as to how can I fix this issue?

Please contact with ADLINK for the support.

I just wanted to know if there is a method I can use to reset the eMMC completely and try flashing it again with the correct BSP.

I don’t think flash board mistake will cause such situation.

How about your just flash xavier BSP to the board? What will it show?

i tried running the command ´$ sudo ./flash.sh --no-flash jetson-xavier mmcblk0p1` --no-flash jetson-xavier mmblk0p1" and it runs through properly with ‘system.img built successfully.’ Complete log file attached.
log_no_flash.txt (23.3 KB)

I am able to even boot up the device with the current ROM and here is the output from jtop :


Every hardware detail corresponds to Xavier.

Please share me the boot log.

And your command to run —no-flash is wrong either…

That is not for NX but AGX Xavier.

I really don’t understand what you are doing here. We asked you to flash the board and you just show me the result of “–no-flash”. This parameter is already obvious enough to tell you “it didn’t flash anything”.

No need to mention that you are posting a AGX Xavier result.

Sorry for the misunderstanding. Please find the output log the flash command sudo ./flash.sh jetson-xavier mmcblk0p1 attached.
log_flash.txt (45.1 KB)

Hi,

“jetson-xavier” is for AGX not for NX… I already said that in previous comment.

Pick the NX one to flash your board…

When you flash the wrong SoC, the flash process would just hit error.

Even same SoC but different module case like AGX and NX would hit such issue. No need to mention NX/Nano case.

If you can flash your module with NX config, then I can say it is a NX module, not Nano.

The flash was successful, and I am able to boot the jetson device and it is working
log_nvmflash_nx.txt (58.4 KB)
. Please find the flash log for the command $ sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1 attached.
I am confused as to why is the Usb device shown as 0955:7020 NVidia Corp and when I get info from Jtop the Module is shown as P3668 and Board P3509-000 ?
Although when I am in recovery mode, the device is always shown as “0955:7e19 NVidia Corp

lsusb is only correct when the board is in recovery mode.

After system boots up into linux, there would also be a usb interface. And that one is always 7020 for each jetson platform.

Yeah, according to the log, your device is a jetson NX, not Nano.

Thank you for guiding me through the whole process. I am still not able to wrap my brain around it as the device is marked as based on Jetson Nano.
I also tried changing the mode to 15W 6Cores thinking since it wasn’t supported by Nano it might crash, but it didn’t. Even Jtop also shows all the six cores up and running. Anyway I can confirm it without opening the device box?

Yes, it is a NX.

We use a eeprom in the module which will not be erased as emmc in each reflash to record the module info. When it is p3668, it is jetson NX. A data corruption in eeprom is unlikly to change p3448 (jetosn nano) to p3668.
Thus, sdkmanager’s detection is correct from the beginning.

1 Like

I verified the hardware directly. It is indeed NX, with a confusing Jetson Nano Label by the Supplier. Thanks a lot for resolving the issue :)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.