XBox360 / JoyStick Drive / Bond mapping error

Hi,everyone!
I am trying to get output of Xbox360 controller on the TX2, using joystick driver.
I found that the output can’t match the button I push, for example ,I push button “start”,but the output is “right shoulder”.
I try the same code on my PC ,which is amd_x86_64 Ubuntu16.04, it’s correct though.
To prove the problem is not on code, I tried the follow cmd:

jstest /dev/input/js0

and I found that when I triggered the left/right trigger,which should be analog value obviously, but the output is definitely discrete value.I mean whatever position the trigger is pushed,the output only get two result,but the left stick appears correctly, changing by the position of stick.

so I think the Xbox360 joystick controller does not return right signal to js0.
I use wired and wireless Xbox360,and they both wrong, but the button-output map are the same.

Have you guys ever met this problem? please help.

I mean I tried :

cat /dev/input/js0 | hexdump

Hi,
We have topic about Logitech joystck and it requires to enable certain config:
https://devtalk.nvidia.com/default/topic/1042633/jetson-agx-xavier/no-data-being-updated-from-joystick-in-o-p-of-sudo-jstest-dev-input-js0-solved-/post/5289799/#5289799

Not sure about Xbox360 controller. Other users may try it on TX2 and can share experience.