Orin Nano - jetpack 6.0: Microsoft xbox 360 joystick USB stick is recognised but js0 is not coming at $ ls /dev/input/js0

for this command “sudo xboxdrv -v --no-uinput” its working , but "$ ls /dev/input/js0 "

error:"
l cannot access $ ls /dev/input/js0 : No such file or directory.

i have did the following but not solved:

sudo apt-get install xboxdrv
sudo apt-get install joystick -y
sudo apt-get install jstest-gtk -y

please help me .

with regards
Hemsingh.

1 Like

Hello,

Welcome to the NVIDIA Developer forums! Your topic will be best served in the Jetson category.

I will move this post over for visibility.

Cheers!

ok please. till now no solution .

Which exact model of Jetson is this? For example, is this the Orin Nano? Also, which L4T release? See “head -n 1 /etc/nv_tegra_release”.

Monitor “dmesg --follow”. Watch for new log lines, and then plug in the joystick. What new log lines show up as a result of this plugin?

Hi,
sorry for late reply,
its R36 , REVISION 2, Orin Nano developer kit board .

for dmsd --follow command no change in log out put. before plug in the joystick usb and after plug in joystick plug in the result is same.

regards, Hem.

Which connector are you using? Does “dmesg --follow” show anything for any other device you plug in? I ask because:

  • One connector is device mode only. It can’t handle other devices like mice. Nothing would be detected if you plug a device into that port.
  • There wasn’t even detection of anything being plugged in. Normally USB detects something even if it doesn’t know how to use it.

Does any other device work when plugged into that port? Does “dmesg --follow” see any log lines as a result of any device in the port?

when I plug in joystick no change in “dmseg --follow” command . but for other device plug in like mouse there is change in output data for “dmesg --follow” command.

This suggests a failure of the joystick. To not even detect a plugin is quite odd. Do you have another Linux computer you can monitor “dmesg --follow” on, and then plug in the joystick to see if anything shows up? Also, tell me about any USB HUB that might be related, especially if that HUB is powered externally, or instead it is powered by the USB plug.

when we can expect the jetpack 6.0 production release with all GPIO working?

I am having a similar issue where my joystick (Logitech f710) does not show up in /dev/input/ as js0

This is only in jetpack 6. I have tried this on an Orin agx and an Orin nx

An Xavier nx on jetpack 5 and a raspberry pi 5 works though.

I do get a response on dmesg acknowledging that the usb dongle is recognized.

Whenever you want to debug this be sure to post the complete log of the dmesg from the plugin. You might also want to include a copy of “/proc/config.gz” (attach to the forum).

Btw, GPIO is unrelated to the joystick (I am assuming USB).

on jetpack 6.0 PR , xbox 360 wireless joystick is not working.

Any solution??

…Hem.

No idea, I don’t have one. Is it a USB dongle you plug in? If so, then you’d need the log messages which occur as the result of plugging that in. This would tell us if USB has assigned a driver, and that’s the first step.