Xorg.log flooded with DFP-0 connected messages

When the monitor is in “sleep” mode, i.e. when the xset standby interval has elapsed, the Xorg.0.log file is flooded with the following block of 8 lines. Repeats approximately every 2 seconds. So that overnight, for example, when the computer is on but the monitor in standby, the Xorg.0.log file builds by roughly 650K bytes per hour. Maybe harmless, but certainly a nuisance. And if a bug report is needed do you really want 50 to 100 Megabytes of this message repeating…

[ 4632.304] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): connected
[ 4632.304] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): Internal TMDS
[ 4632.304] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): 330.0 MHz maximum pixel clock
[ 4632.304] (–) NVIDIA(GPU-0):
[ 4632.319] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): connected
[ 4632.319] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): Internal TMDS
[ 4632.319] (–) NVIDIA(GPU-0): HP 2009 (DFP-0): 330.0 MHz maximum pixel clock
[ 4632.319] (–) NVIDIA(GPU-0):

You will see that there are 2 identical blocks of 4 lines separated by just 15 milliseconds.

How can I turn this “feature” off? I tried [Option “ModeDebug” “false”] in xorg.conf to no effect.

[Linux 3.16.7 x86_64 / Nvidia driver 367.44 / GTX 750Ti] info.

It is related to the 367 driver, I have the exact same Graphics Card and was getting the exact same messages I went down to the previous release of the driver 340.98 and I have not received any messages in my logs since I switched!

I downloaded the 340 package rebooted into non graphical mode, ./NVIDIA-… --uninstall
so that i can remove the currently installed driver.

Immediately after I installed the 340 driver and seems to be going smooth without any log messages filling up the logs which is nice!

Hope this helps!

Alex

This EXACT problem is occurring on two of my workstations now. It is odd, because we are all running the same video card, similar motherboards, same distro (gentoo) with nearly identical packages installed, and yet only 2 of my 4 workstations are experiencing this:


[495281.510] (–) NVIDIA(GPU-0):
[495281.523] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): connected
[495281.523] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): Internal TMDS
[495281.523] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): 340.0 MHz maximum pixel clock
[495281.523] (–) NVIDIA(GPU-0):
[495281.537] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): connected
[495281.537] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): Internal TMDS
[495281.537] (–) NVIDIA(GPU-0): AOC 2752H (DFP-1): 340.0 MHz maximum pixel clock
[495281.537] (–) NVIDIA(GPU-0):

It is sometimes taking 10-15 minutes for the machines to finish writing to the logs and allowing a login. Do I really have to revert all the way back to the 340 driver?? We are on 396.24. Or Should I ditch the official driver for noveau?

I’ve tried swapping cables around, but no change. I also believe it might be related to the monitors as that is the one thing in common between the two failing workstations and the two working ones.

Seriously though, this is unacceptable so I need to figure something out. Please help!!!

What DE are you running?

DE? Desktop? XFCE, the problem started when we switched login managers to lightdm

Hmm… Could it be because of the ACPI daemon?? I just realized that both of the problem workstations were not running the daemon, whereas the working workstations all have ‘acpid’ running. I can’t believe I didn’t pay it notice before, but right before the looping log message there is typically this:


[449471.173] (II) NVIDIA(0): Setting mode “DVI-I-1: nvidia-auto-select @1920x1080 +1920+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}”
[449471.323] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[449471.323] (II) NVIDIA(0): may not be running or the “AcpidSocketPath” X
[449471.323] (II) NVIDIA(0): configuration option may not be set correctly. When the
[449471.323] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[449471.323] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[449471.323] (II) NVIDIA(0): details, please see the “ConnectToAcpid” and
[449471.323] (II) NVIDIA(0): “AcpidSocketPath” X configuration options in Appendix B: X
[449471.323] (II) NVIDIA(0): Config Options in the README.

I kind of hope it isn’t this simple of a fix as I have been spending a little bit of time on this every single day for a few weeks now, all while ignoring that error. BUT if this does solve things (and it seems to help so far) then at least hopefully other people that encounter this error can be pointed in the right direction to fix it a lot faster than I did.

Let me explain why I cannot immediately identify this as a fix: The looping log message would really only occur after the workstations were locked for long periods of time. So typically in our office, this was during the first unlock at the start of the work day. Any other times during the day, the unlock process didn’t seem to have a problem. Therefore, I cannot confirm this behavior has been resolved until tomorrow. I did a lock/unlock of the screens and saw the same behavior whether the ‘acpid’ was running or not. But I am going to leave it running over night and report back in the morning if that solved the problem tomorrow morning. Hopefully this resolved it!!

Ugh :( This did not resolve it for on workstation but the other one now seems fine (although it did get rid of the message on both). So… maybe it is related, maybe not.

Any thoughts from the Nvidia Dev team?!??