2080Ti GPU Drivers not working on Linux

I have just purchased an nvidia 2080Ti gpu. I have been for 2 days trying to install the drivers on linux (have tried ubuntu 18.x, 16.x , linux mint, arch linux) and several of the drivers available online but it seems not to work.

nvidia-smi shows no devices were found!!!

The screen freezes if I try to use the nvidia gpu as the main gpu

Do the drivers actually work? Or how can I make it work?
nvidia-bug-report.log.gz (551 KB)

Please check if you have secure boot enabled in bios and disable it in that case.
Which driver version are you using and how did you install it?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Yes, secure boot is disabeled

I have just run the report using the 410.93 driver (NVIDIA-Linux-x86_64-410.93.run).
I get the exact same issue with other 410.x drivers and 415.x
I install it by running sudo bash NVIDIA-Linux-x86_64-410.93.run and rebooting
(have also tried running it blacklisting nouveau but nothing changes. nvidia-smi does not detect any device)

This report is run on ubuntu 18.04, with the main gpu as the motherboard. Using the NVIDIA gpu as the main one and using the nvidia drivers freezes the screen when starting ubuntu.
nvidia-bug-report.log.gz (551 KB)

Using the .run installer is kind of sub-optimal and it looks like you now have a mix of the 390 driver from Ubuntu and the 410 driver from the .run installer.
Please follow these instructions to have a clean system:

  • Don’t use the .run installers, use --uninstall to uninstall them
  • purge anthing nvidia/cuda
  • add the ubuntu graphics ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  • install the driver from that (sudo apt install nvidia-driver-415)
    Currently, the Nvidia gpu fails to initialize which might be due to hardware but hard to say until you have a clean setup.
    The error from dmesg:
[   13.794728] NVRM: RmInitAdapter failed! (0x26:0xffff:1127)

If the nvidia gpu still fails after clean driver setup, check for properly connected power supply, reseat card, try a different slot, check for a general hardware failure in another system.

Yes, we also tried installing the drivers in a clean ubuntu environment (incl. purge) and adding ppa.
Now I have installed Windows and tried the gpu with the nvidia drivers and it does not work. It sounds like there is something wrong with the hardware

Ok, see if removing the card and properly inserting it again helps.