331.20: FXAA doesn't work with deferred rendering on GTX460

Hello,

I’m trying to get FXAA working on my GTX460 with FlightGear.
FlightGear is a flight simulator providing 2 rendering scheme: “default” vs “deferred”

This image is a summary of the test I’ve done: http://uppix.net/2kw8RK.png (Feel you free to zoom in , the image is large)
As you can see only (3) has a working anti-aliasing (anti-aliasing slider is at full right)
When FXAA is disabled, anti-aliasing slider is at full left in nvidia-setting
When FXAA is enabled, anti-aliasing slider is at full left in nvidia-setting

I learnt that a “deferred” rendering is only able to apply anti-aliasing with FXAA.
I would expect that (5) give me the same result than (3). But it’s not the case.

Some information about my system:
Linux Mint 16 Petra (Cinnamon) - GeForce GTX 460 SE
nVidia driver: 331.20-0ubuntu1~xedgers~saucy1 (installed via package manager from ppa:ubuntu-x-swat/x-updates)
Software used: FlightGear 3.1.0 (dev version from https://gitorious.org/fg )

My nVidia report log: http://s000.tinyupload.com/index.php?file_id=28747237122036063187

Talking about FXAA with another FlightGear user he sent me 2 screenshots:
FXAA disabled: https://sites.google.com/site/grtuxhangar/home/download/Shawnee_.png
HXAA enabled: https://sites.google.com/site/grtuxhangar/home/download/Shawnee-FXAA.png
This user has a GTX560 TI with Linux OpenSuse - 331.38

I conclude that FXAA is working with deferred rendering on Linux.

The challenge here is just to know why it doesn’t work for me (and eventually having it working).

Thanks in advance for your support,
Regards,
Clément

Did you tested with latest drives ?

ftp://download.nvidia.com/XFree86/Linux-x86_64/331.38/
ftp://download.nvidia.com/XFree86/Linux-x86_64/334.16/

I’ve tested with 331.38 but FXAA still not working.
334.16 is not in my package manager and I’m not ready to install it “manually” (I’ve crashed my system in the past with .run file, so now I use only the driver provided by my package manager)

I have a dual boot “Linux Mint 16” / “Windows 7”, on Windows 7 FXAA works fine for both default rendering and deffered rendering (driver 319.??)

Is it possible that Cinnamon (gnome derived) is the culprit ? All other users who reports a working FXAA on Linux are using KDE.

Regards,
Clément

Filed Bug 1461550 to track this issue. PLz provide any other information that will help us to reproduce this issue in house for investigation.

clemaez, We are not able to find deferred rendering settings on in game and NVCPL. Where we can find the deferred rendering settings? Also Can you please share the NVIDIA-settings FXAA option page screenshot?

Hi,

Sorry for the delay, I have no email who tells me that an answer has come here until I receive a PM from you.

In order to use the deferred rendering in FlightGear you have to start with argument --enable-rembrandt
For more details: http://wiki.flightgear.org/Rembrandt
./fgfs --enable-rembrandt

My nVidia-settings FXAA page: http://uppix.net/EvU8FV.png

Thanks you for looking at this problem.

Regards,
Clément