470.xx introduces light flickering on Adaptative Sync monitors

Per my comment on the Pop_OS repo at 470.42.01 beta: https://forums.developer.nvidia.com/t/linux-solaris-and-freebsd-driver-470-42-01-beta/181536 by leviport · Pull Request #108 · pop-os/nvidia-graphics-drivers · GitHub :

Installing the 470.42.01 beta driver on Pop_OS 21.04 beta release introduces a very faint but headache-inducing backlight flickering on adaptative sync monitors, whether GSync or Freesync-Gsync-Forced. The issue does not appear to affect non-adaptative-sync monitors - I have 3 monitors, two of which adaptative, and only the non-adaptative one was fine.

The one other difference between all monitors (and my Index - unused on 470) and the non-adaptative-sync monitor is that the non-adap is using HDMI.

1 Like

Same issue with 470.57.02 - and when I disable adaptative sync on my ultrawide, said monitor doesn’t exhibit backlight flickering issues anymore.

Meaning something at the driver level is impacting the light level through draws only on adaptative sync monitors somehow?

Just a general user here (gamer) with the same issue.
I noticed it start after updating past 466.77, which is the only driver version (that I’ve found) to not cause the flicker. I’ve tried all 3(? lost track) of the game ready drivers since, and they all cause flicker.
Even gave the Dell packaged Nvidia driver 466.79 hoping it would work being made for my system, but it too caused the flicker.

I mostly notice the flicker when opening and closing apps that activate Gsync. But I usually first notice the flicker in loading screens of games like Knockout City or Rocket League, then the issue permeates into all Gsync activity.
My best (self educated) guess is a possible frame limit issue, only because it occurs (at first, it seems) when my GPU is not maxed out, like during loading screens, when at max FPS. But it does resemble a backlight flicker, mostly because it’s most noticeable with backgrounds of solid colors etc.
I’ve tried everything under the sun, clean install of everything possible, short of a clean Windows install. When the flicker first started for me, there had been a few updates, from Nvidia, Dell, and Windows, I tried rolling back all of them individually, and tried the GPU drivers last (even with factory default settings), 466.77 is the only working version for me.
Any version past that, with Gsync on, the flicker comes back.
I can’t stand it lol
I’m pretty certain it’s the same issue
I submitted a issue to Nvidia ages ago when I first noticed, they said it would be fixed in the next update, but there’s been at least 3 drivers since, and none fix the flicker

Alienware R11

Alienware AW2720HF (240Hz)

i9-10900KF (OC)

RTX 3080 (OC)