Ubuntu 20.04 - Laptop Display is Black+Flickering after logo, External Display is Fine

My laptop has had an issue where - when trying to use the discrete GPU (GTX 1070 Mobile), the laptop display is black with some random flickering and horizontal lines. The screen appears fine during the boot sequence, but after the “Ubuntu” logo goes away and the login screen appears, the flickering starts. Even the ctrl + alt + F-key terminals are unusable.

However, when connecting to an external display via HDMI - everything appears fine on the external display (the laptop display remains useless, though - blank & strobing).

If I change the GPU mode from “Discrete” to “Hybrid” in my PC BIOS, though, and utilize the integrated Intel graphics (with the mesa driver), the display works fine. (I’ve since set the GPU mode back to “Discrete”, fyi.)

Thanks

PS: The laptop display is G-Sync capable and reports itself as being connected via displayport, if that’s relevant.

nvidia-bug-report.log.gz (422.9 KB)
allconfig.txt (6.7 KB)

From driver perspective, everything seems fine. Please check for a regression by downgrading to driver 470 or even nouveau.
BTW, the display doesn’t seem to be g-sync capable, maximum refresh rate is 60Hz.

1 Like

Using the 470 driver didn’t make any difference and using the nouveau driver caused it to fallback onto llvmpipe for graphics (which does display properly on the laptop display, at least). I removed the nvidia-installer-disable-nouveau.conf modprobe, and rebooted, but that didn’t seem to resolve the issue.

In terms of the G-Sync - Only really matters if it could be contributing to the issue, but: While I’m not sure if it would meet the current definition of G-Sync (I think I remember there being some revising when they added “G-Sync Compatible”), it does still have the G-Sync sticker on it and NVidia X Server Settings tool detects it as such:
image
(Laptop is a rebadged Clevo P650HS-G)

I have tried to debug the issue in the past. Is there anything that my past self could have messed with that comes to mind as possibly explaining the issue?

Thanks

No, I don’t think so. I rather suspect for some reason the driver doesn’t get along with the internal display. Since for a g-sync capable display the range is quite minimal (48-60Hz), please try disabling gsync in nvidia-settings to test
nvidia-settings -a AllowGSYNC=0

1 Like

Changed back to 470 driver, and used that command to disable G-Sync (apparently AllowGSYNC has been deprecated in favor of AllowVRR), but no luck.

If at all useful, I filmed the issue: Screen Flashing (Epilepsy Warning)

Flashing experience. Unfortunately, I don’t know of a way around it other than maybe fiddling with the mode timings. Does it work in 48 Hz mode?

Sadly, changing the refresh rate made no noticeable difference.

If you have any other ideas, I’d gladly test them out, but at this point I’ve kinda resigned myself to finding a long weekend to try backing up my files and giving PopOS a try or something.

You could switch back to hybrid and create a new nvidia-bug-report.log, maybe some differences are visible.

Thanks for the help. I wound up spending the past few days backing up my files trying out PopOS. It seems to work better, though still has some issues that I recall encountering when using Ubuntu - e.g. when waking from suspend or switching back from an F-key TTY, the screen gets all flickery.

Oh, and I think I may have been unclear in the initial post: It used to work fine when enabling Hybrid mode in the BIOS, but only after uninstalling the NVIDIA driver (i.e. only using the integrated graphics; the BIOS only has “Hybrid” and “Discrete” as options).