5.2.x network & display issues

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.7.0.8846
other

Host Machine Version
native Ubuntu 18.04
other

After flashing AGX with DriveOS 5.2.x, there is no IP for eth0 and also no display:

  1. Different from host IP forwarding as mentioned in the SDK Developer Guide, in order to set the static IP for XavierA/B to directly access the internet w/o going through host, what is the procedure step by step, could NV please summarize the one-stop solution to achieve this goal for eth0?

  2. What are the operation steps to enable Ubuntu desktop for DriveOS 5.2.0/5.2.6 on AGX?

Hi, @hfkou

Please create different topics for different problems. May we know which issue you want to discuss in this one? Thanks.

How about the 1st for now, thanks

Thanks. Please help to update the title accordingly.

Please let us know what’s the network issue. In my experience, I don’t need to manually set up anything and it can get IP from the DHCP server.

title and original questions are updated as shown above

Please refer to Finalize DRIVE AGX System Setup (Linux). Thanks.

The following works for my 1st question regarding static IP setting, share here for reference:

sudo ifconfig eth0 x.x.x.x/23 up
sudo route add default gw y.y.y.y
sudo vi /etc/resolv.conf to add

  • nameserver z.z.z.z

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.