8200 IGP - which driver version?

I have a motherboard with an 8200 IGP.

02:00.0 VGA compatible controller: NVIDIA Corporation C77 [GeForce 8200] (rev a2)

Distro is Arch Linux. I am stuck at 319.32. This is the last version of the nvidia dirver package which would not crash my system. I have tried later packages but all of them would produce a system freeze. Now with the appearance of xorg-server 1.15 this rather outdated package is no longer compatible. Not to mention that it is not compatible with the newer versions of the kernel.

At your download site when I enter my card details the recommended driver version is 319.76.

Why? What’s the situation here? Supposedly the current long-lived branch should support Geforce 8 and newer products. Why then it does not work with my 8200 IGP?
nvidia-bug-report.log.gz (63 KB)

It should work with later drivers. If you’re having crashes and system freezes with the latest drivers, you might have to submit a bug report.

There is something definitely here. And I think that nvidia are quite well aware of it. If you look at the supported products lists for 319.76 and 331.38 the part concerning 8xxx is changed from:

GeForce 8 Series:

GeForce 8800 Ultra, GeForce 8800 GTX, GeForce 8800 GTS 512, GeForce 8800 GTS, GeForce 8800 GT, GeForce 8800 GS, GeForce 8600 GTS, GeForce 8600 GT, GeForce 8600 GS, GeForce 8500 GT, GeForce 8400 GS, GeForce 8400 SE, GeForce 8400, GeForce 8300 GS, GeForce 8300, GeForce 8200


GeForce 8 Series:

GeForce 8800 Ultra, GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 GT, GeForce 8800 GS, GeForce 8600 GTS, GeForce 8600 GT, GeForce 8600 GS, GeForce 8500 GT, GeForce 8400 GS

Apparently anything below 8400GS is missing form newer releases. Why?
An official comment from someone form nvidia would be appreciated.

The 8400 GS should be supported by the latest driver available currently, 331.38. If it’s not working, please generate and attach an nvidia-bug-report.log.gz file.

My question is not about 8400 GS it is about 8200 IGP.

Why is it not listed as supported in the later driver releases? Why do these releases crash my system?

Sorry, that’s what I meant. I don’t know why it’s not listed on the download page; I assume it’s just an oversight. The authoritative list is Appendix A of the README.

As I mentioned previously, please follow the instructions in the sticky posts about how to report a problem so that we have enough information to be able to try to help you.

I tried the latest driver 331.38 together with kernel 3.12.8. Same result. The system froze within seconds of starting X with a single XBMC running. I just managed to run remotely nvidia-bug-report.sh before this happened. The log is attached to the top post.

Is the bug report log enough? Do you need some additional information?


I am running 3.12.9 Kernel with Nvidia GeForce 8200M G and I can confirm that the 331.38 linux driver does not work for some of the “supported” cards, nor does the 319.76 driver for my particular model.


I am running kernel 3.13.0 (Ubuntu 14.04) with GeForce 8300 integrated graphics (ASUS M3N78-EM).
Drivers 331.38 (supplied by the distribution) and 331.67 (supplied by PPA xorg-edgers) completely freeze the machine a few seconds after using the X desktop.
Drivers 304.117 (supplied by the distribution) and 304.121 (supplied by PPA xorg-edgers) work properly.
This seems very similar to those 8200 issues.

Also see other guy with similar issues here:

6 months and still no fix for this bug? The latest linux drivers, 340.24, are unusable with the 8300 IGP (ASUS M3N78-EM) despite them being listed on the supported products list. I experience hard freezes and lockups when playing videos with vdpau enabled which requires a hard reset. I had to downgrade once again to the last known working version that I’ve tested, 319.49. I cannot upgrade to xorg server 1.15 and I can’t upgrade to a kernel > 3.10 with this IGP. Would you please fix this bug?


Similar problem for GeForce 8200, Kernel version 3.15.5, NVIDIA GLX Module 340.24.
I disabled MSI interrupts for the NVIDIA kernel module:
No crashes seen so far.

No bug fix but maybe also a workaround for you?
@NVIDIA: please fix!

I just tried nvidia driver 343.13 and kernel 3.10.9 with MSI disabled. It caused udev to hang on boot. Any other suggestions? Nvidia, please fix this bug.


“The Linux 340.* legacy driver series is the last to support the G8x, G9x, and GT2xx GPUs, and motherboard chipsets based on them. Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 340.* legacy releases through the end of 2019.”

R343 and later drivers no longer support GeForce 8/9/100/200/300 GPUs aka Tesla (OpenGL 3) generation, only Fermi, Kepler and Maxwell (OpenGL 4) generation is supported.


The last driver series for the Tesla generation hardware is 340 and 340.32 is the latest driver atm.

Sorry, I havn’t found this until now.

340.32 is exaclty the driver I tried a few days ago, same results as described here:

I am running 304.xx safely (and did run 319.xx with success). Is this solved for anynone here? Should I try a bug report?

The suggestions linked to in post #13 worked for me here so far, meaning I am running 340.32 on Geforce 8200 without a crash.

A suggested there, I added

options nvidia NVreg_EnableMSI=0

in one of the files ending with “conf”, e.g. in my case /etc/modprobe.d/video.conf.

I was stuck to old driver serie 304 because every recent drivers crashed (IGP Geforce 8300 on ASUS mainboard). Disabling MSI also fixes the issue for me:

  • either disable on system level: by adding: pci=nomsi to kernel boot command line
  • or just disable for nvidia module: by creating a file named nvidia_whatever.conf in /etc/modprobe.d with: options nvidia_340 NVreg_EnableMSI=0 remark: exact name for the module can be checked using: modinfo nvidia

Verify then that the module does not use MSI anymore using:
cat /proc/interrupts | grep -i nvidia

While the workaround of using options nvidia_340 NVreg_EnableMSI=0 still works well, I re-checked with last version 340.96 of the driver, especially because the change log says:

``NVIDIA is working on a long-term solution to improve the driver’s out of the box compatibility with system configurations that do not fully support MSI.’’

Result: no change. Exactly same freeze / unstability if re-activating MSI.