How to select drivers for both 1080 and 2080?

I am a Ubuntu user and my computer just cannot start after an update. Then I found it is because the latest driver of 460 does not work for my display card 1080 anymore. 1080 only accepts 390 as its driver.

But with 390, the nvidia-smi does not show 2080 anymore. May I know why this is happening? I am using 1080 as my daily use card and 2080 as my DL project training card. I really need to have them work at the same time.

Anyone could help?

I don’t know how to solve your problem but I’m pretty sure that the 1080 should work with the newer driver as somehow I’m running 465.27 on my 770M. I don’t think that’s why it is not starting as expected

I haven’t solved my problem yet. I am very confused too! It at least worked with 440 before. Not sure why it suddenly stopped work and I don’t know how to debug it. If I change the driver, my computer cannot boot and will freeze on the mother board logo screen… Is there a way to check where is wrong?

Can you please run sudo and attach the resulting log file here?

A while ago there was a rash of counterfeit GPU products being sold online that reported themselves as things like the GTX 1080 but were actually legacy GPUs that had been modified. If your “1080” only works with the 390 series drivers then that’s an indication that it might be fake. A bug report log would hopefully say for sure.

Another telltale sign of a counterfeit GPU is if it’s reported as a Pascal GPU (e.g. GTX 1080) but it has a physical VGA port on the board.

Edit: I just realized you said the 440 series drivers were working, so that throws out that theory. A bug report log from the non-working configuration with the latest (release 465) drivers would hopefully help diagnose what’s going wrong.

This is my report:
nvidia-bug-report.log.gz (319.6 KB)

My card does not have a VGA port and it does not look like anything older. It may be fake, but I am pretty sure it’s not modified from a odler model.

Regarding the “A bug report log from the non-working configuration with the latest (release 465) drivers”, do I have to install 465 driver to get it? That’s not really feasible since my machine won’t boot with any driver older than 390… is there any way to circumwent it?

From the information in the bug report log it doesn’t seem like the 1080 is fake, so that’s a good sign. Of course the 390.143 legacy driver doesn’t support the RTX 2080 Ti but it looks like the 1080 is working fine in this bug report log.

When you say that the computer “cannot start”, what exactly is the symptom of that? If it’s a black screen at boot, can you get to a text console by pressing Ctrl-Alt-F2 (or F3, F4, etc.)? If not, can you connect to the system over the network using SSH?

Thanks so much for the effort.

I can enter the BIOS setup. But after the BIOS selection screen (the screen with del and F2 line), it will enter a screen with only ASUS logo (I use an ASUS mother board) which will only lasts for seconds in normal. I think it should be the grub waiting screen. If I use any driver higher than 390, it will freeze there without responding to any keypresses. This is why I cannot do any debug myself…

I cannot enter any tty (Ctrl-Alt-F2 does not work) and I don’t think the system is up in any sense. I couldn’t enter the grub page thus I couldn’t enter safe mode (i only tried F1-F9 keys, i am not sure that’s they right way to enter grub page). I never tried SSH since I don’t think SSH is up. Currently I am using 390 and upgrading it is a high risk action… I hope we can have a possible hypothesis and a through plan before any trying.

Does anyone know anything similar? I saw a post at Black screen after installing Nvidia driver in Ubuntu 20.04 LTS, but I am not sure whether it’s the same issue since I am blocked at the logo screen instead of black screen.