Add target crashes the initiator system with MLNX_OFED-1.5.3-3.0.0

Hi Guys,

I’m just running into a strange problem, I try to through SRP to a target and can find the target by ibhosts and ibsrpdm. but when I run command like below to add target on initiator, it crashes the system immediately(system reboot)

echo

-n max_cmd_per_lun=256,id_ext=0002c903005836ae,ioc_guid=0002c903005836ae,dgid=fe800000000000000002c903005836af,pkey=ffff,service_id=0002c903005836ae,initiator_ext=0x0002c90300583b53

>/sys/class/infiniband_srp/srp-mlx4_0-1/add_target

the target works well with intiator on MLNX_OFED-2.0, but this problem occurs on MLNX_OFED-1.5.3, anyone has met this issue before or has any suggestion? thanks a lot.

Environment:

Initiator:

SLES 11 SP2, MLNX_OFED-1.5.3-3.0.0, firmware

2.9.1/2.11(two HCAs on initiator, no bonding, tried replace firmware but

didn’t help)

Target:

Mellanox ConnectX-3 HCA, target and initiator connect

through switch.

eyang https://community.mellanox.com/s/profile/0051T000008EaldQAC - Did you get this resolved?

John

Just to let you know that only SRP-Initiator is included in MLNX_OFED for Linux (1.5.3 & 2.0), which is actually based on open source from OpenFabrics, however, this package does not include an SRP Target. It’s within the storage-vendor provider’s responsibility to supply, support and ensure SRP target is fully

compatible with OpenFabrics. This may explain the problem you encountered.

Avi

Yang,

Thanks so much for the question let me see if I can get the right guys on this one.