addKernel launch failed: no kernel image is available

Sorry for this newbie question, but I’ve looked at a bunch of similar posts and the answers haven’t helped me. So now I’m stuck.

My configuration:
Windows 10 laptop with Quadro K1100M (compute capability 3.0, Kepler)
CUDA 10.0 (support for compute capability 3.0 – 7.5 (Kepler, Maxwell, Pascal, Volta, Turing).)
Visual Studio 2017

I created and built a default CUDA project, but when I get this error upon execution: addKernel launch failed: no kernel image is available for execution on the device.

I then noticed that the default VS properties were set to “compute_35,sm_35” for CUDA code generation, and changed them to “compute_30,sm_30”. But the problem persists.

Can anybody help me out with what I might be missing? At this point the only thing I can think of is to try an older CUDA version.

Any help would be greatly appreciated.


I suspect something in the MSVS IDE still needs adjusting. You can confirm this by building from the command line instead:

nvcc -arch=sm_30 -o addKernel.exe

If that works, carefully go through the MSVS IDE settings again. Sorry can’t help you there because I never use the IDE.

Problem solved. Basic user error. I have both VS2017 and VS2019 installed, and the Properties for this project were pointing to the VS2019 Windows SDK Version. Once I corrected the Windows SDK Version to be the correct version for VS2017, everything worked just fine. Hope this helps somebody else down the road.