After flashing the TX1 the board stays in recovery mode


I have a TX1 board that worked fine. It had 3.x version of Jetpack. So I recently flashed it with Jetpack 4.3 using the script by following the Nvidia Quick start Guide ,from a Ubuntu 18.04 host machine.

The flashing was successful but the board did not cold boot (I didn’t see anything physically happening on the board like the recovery led switching off). I tried powercycling it as well, but the recovery LED stays on.

Is this a hardware issue? Or do I have to follow some procedure to boot the device normally?

Recovery mode does not have an LED. This is just power. After a flash the unit will attempt to reboot. At that time you would enter the first boot information. In JetPack 3.x the accounts already existed, and had default passwords…in 4.3 it becomes necessary to create the account and password at first boot.

If you really want to know what is going on, then serial console is the way to go. If you plan on working on anything embedded, then it is hard to image not having serial console. See:

What often happens is that someone is using a monitor which does not work, and the system has really booted, but it isn’t visible. In that case you could still ssh, but without that first account setup ssh is kind of pointless. Ping (if you know the IP address) should still work though.

Is your monitor purely HDMI? If it is VGA, then the only way it will work is if you get lucky and a default mode is compatible with that monitor. If your monitor is HDMI, then you’ll want to save a serial console boot log to post here.

Thank you for your reply. What threw me off was that both the power and recovery button had green LEDs lit up. And I wasn’t seeing any reboot activity on the monitor as well.

But you are right, it was a monitor issue at that point. My monitor is HDMI (a Lilliput non-HD portable) but it wasn’t displaying anything. So I tried it on another HDMI display(after reading your reply) and it was indeed booting up. I was able to create the account. Everything is working fine.

Later on when I connected the former monitor, that worked fine as well. So I’m not really sure what happened there.

Cheers for the help.

The video driver was designed to work with the HDMI monitor’s self-reported configuration data (the DDC wire, which has EDID data). VGA does not really support this, nor do some of the older analog DVI (if you find VGA claiming to support this, then likely it is using an older revision which won’t work with the NVIDIA graphics software, and for all practical purposes, has that DDC wire cut). Once a mode is set up, then you can connect something like a VGA monitor and it will work if that mode is within the capability of the VGA monitor. HDMI is hot plug, but a VGA does not trigger a connect event, or at least it does not trigger a “reconfigure” to the new connect since there is no data to reconfigure with.