Jetson TX1 not booting / starting

Hi! I got the TX1 today. I followed the steps in the official guide but the board is not starting up. I have been working with TK1 before this so I am aware of most details of these boards.

Debugging Steps:

  1. HDMI does not work or show any info. I have tested using different displays.

  2. 2 Yellow LEDs light up and the fan also spins for fraction of a second. (normal behavior)

  3. If I connect my keyboard directly to USB port, I cannot get caps lock, num lock etc to light up. I suspect no power on the port too.

  4. I have connected the board via ethernet to my linux desktop that shares internet via eth0. Even after connection eth0 shows status as disconnected.

  5. I have tried the reset button too.

  6. I have pushed buttons in powered off mode to drain any static due to capacitors.

  7. Board is completely lifeless except for the two LEDs.

Any ideas on what more I can try?

I noticed the same thing on mine.

I’m flashing it with latest Jetpack to verify if it is a firmware problem.
The board can enter in “Recovery mode”, so I hope is a software problem.

Have you tried to connect to serial debug port to verify if it boots?

[Edit] After flashing my TX1 is fully working

No not yet. I also took it to recovery mode and noticed that only the ethernet was alive. I will probably also try and do the jetpack install then. Please let me know what happens when you try to flash it with l4t.

FYI, so far as I know those LEDs are green…if they really are yellow I’d wonder if that is an error indication. In the case of that not being an error, I’d also suggest flashing. Before flashing you could test basic function via running this command on the desktop host while Jetson is connected via the micro-B USB to host with Jetson in recovery mode:

lsusb -d 0955:7721

If the Jetson shows up with the command above then you know it is at least partially functional.

FYI, I would not consider lack of video to indicate any kind of failure, there are software issues with some monitors which resolve after flash.

Same here. Just unboxed, plugged in, and the only thing I see are the two green LEDs )):
Will try to flash it.

Update: Just tried a bunch of other Displays / Monitors.
Seems the Jetson needs some time until it switches on HDMI, and that some Monitors don’t recognize the HDMI signal.

==> Everything seems OK now. Just a HDMI / Monitor glitch.

Two LEDs lighting: PWR and SOC. Cooler Fan not spinning.

Cooler fan is rarely needed unless there is a significant work load.