New Jetson TX1 does not power up at all

Brand new just opened the box, following the quick start guide,

  1. connect USB keyboard,
  2. connect HDMI monitor,
  3. connect power,
  4. press and release the power button

Basically nothing happens then, the fan doesn’t move at all, no display, the keyboard doesn’t work neither (no light up, tried CAPS lock, not working).

I saw two GREEN lights on the device that are next to the power button light on,
Also there are two RED lights (CR5, CR6) light on, is that normal?

Please advise, thanks!

The fan does not normally run…the TX1 does not produce enough heat most of the time and thus the fan never kicks in…right at power up if you look very closely the fan might “blink” on for a fraction of a second. I don’t know about CR5/CR6 operation.

It wouldn’t be unusual for the HDMI configuration to not work before completing the “sudo ~/NVIDIA-INSTALLER/installer.sh” step. If you have a network router connected you will probably see the DHCP request assign an address…you might try to ping that address, and if that works, log in to account “ubuntu” (default pass “ubuntu”) to run that script.

If ssh does not work, then serial console would be the fallback (it’s rare serial console does not work even under the worst of circumstances). If interested in serial console, see:
http://elinux.org/Jetson/TX1_Serial_Console

Hi garyx99, as you can see in schematic of carrier board, these 4 LEDs on indicates some main power rails of module and carrier board are normal. Did you install Jetpack? http://docs.nvidia.com/jetpack-l4t/#developertools/mobile/jetpack/l4t/2.3/jetpack_l4t_install.htm

Hi linuxdev and Trumany, thank you for your responses!

Dear Trumany – I haven’t installed Jetpack, according to the quick guide, before installing anything, only connect power and HDMI, am I supposed to be able to see an Ubuntu GUI on the connected monitor?

Currently I see nothing, I have tried,
1). connect Ethernet cable to TX1, amber light is up and green light is flashing, but when I ping tegra-ubuntu from another computer, it fails.

2). CAPS Lock on keyboard doesn’t response, but Num Lock can response (light on and off).

3). HDMI cable should be good, I tried to use it to connect to another computer, monitor can display the content.

Do you have any more advice?

Thanks you,

Hi garyx99,

Brand new just opened the box, following the quick start guide,
Have you ever tried to flash the latest BSP (via JetPack 23.2.1) onto your platform?

You won’t be able to ping “tegra-ubuntu” (the name…DNS from your router would map this to a name like “tegra-ubuntu” in some cases) if your host was not set up to see this name via a router which accepted that name for the connection. On the other hand, your router would have logs or web interface to show you which addresses it assigned…you can use that dotted-decimal format address without issue. Any address assignment the router shows is what you want.

Note: There is a final install step in the “~/NVIDIA-INSTALLER/” directory which is needed before GUI works…in theory text mode console would come up to allow this without entering graphical mode, but this seems to disagree with some older monitors (like mine). When I originally ran this to make GUI visible (graphics mode) I had to use ssh (my host is the router so I saw the assigned address in the host’s logs…a real router is simpler and should have a web interface to see connections).

I flashed the lastest JetPack, it looks like the flashing was ok but then JetPack was telling that it cannot determine the target’s IP address, PLUS there is still NO display on my TX1.

Dear linuxdev, what did you mean by “There is a final install step in the “~/NVIDIA-INSTALLER/” directory”?
How to complete that final step?

Also I don’t know how to get the IP address of my TX1, it is on the same switch with my host PC, and both are within a same LAN.

Thanks for your help!

Determining IP address is part of adding new packages after a flash is complete. Actual flash is not affected by this.

The Jetson uses an ordinary DHCP request to get its address. This requires a DHCP response to tell it what to use…either from a router or from a host that is set up to act as a router. Do you have a separate router, or is your host acting as a DHCP server?

On a Jetson TX1 which initially ships with R23.1 you will find directory “/home/ubuntu/NVIDIA-INSTALLER/”. Within this is a script “installer.sh” which must be run with sudo on that version in order to add the direct hardware access files (such as the video driver). When flashing this is already taken care of (it’s the “apply_binaries.sh” step if manually flashing from command line).