AGXXavier cannot communicate properly with Can

Hello everyone, my name is Zihang, I tried to use CAN communication on AGXXavier, I tried his configuration following the web guru’s tutorial (https://medium.com/@ramin.nabati/enabling- can-on-nvidia-Jetson-Xavier - developer-Kit-aaaa3c4d99c9), The transceiver is purchased and installed, but CAN communication still cannot be used. May I ask what is the problem? I tried to use CAN to communicate with a standard CAN device, but received no response.

Sorry for the late response, is this still an issue to support? Thanks

Yes, I still can’t implement CAN communication on AGX Xavier

Hi ChuZiHang,
Please refer: https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hw_setup_jetson_can.html#wwpID0ELHA

Go through the doc completely and check all the possible fail cases.

但是我使用can0发送can1接受并不成功,can1无法接受到发送的消息,反之也不行,我确认我的物理链路没有问题.

Please check CAN clock and bitrate of can0 and can1 using:
ip -d -s link show can0
ip -d -s link show can1
Bitrate should be same to transfer messages. Also CAN pinmux settings should be correct.