An error occurred while the camera was turned on

When I turned on my camera on top of jetson 5.0.2, the following situation appeared.

Attached my dmesg error message.
dmesg.txt (3.0 KB)
Hope you can help me tell me where the error came out.

Did you try v4l2-ctl to verify the sensor driver and HW first.

v4l2-ctl -c bypass_mode=0 --stream-mmap

Yes, I have tried v4l2-ctl. I have 8 cameras, 4 of which can be used. The above error will occur.

I wonder if there is a problem with my device configuration.
tegra194-camera-ar0231-a00.dtsi (30.8 KB)

Modify the serdes_pix_clk_hz to 374000000 to try

Thank you. I tried your method. But it still happened before.

[ 190.982909] i2c_wr8: wr8 register failed
[ 191.184475] i2c_rd8: reading register 0xd from 0x68 failed
[ 191.184485] TI933-68 0xd = 0x8
[ 192.859635] tegra-camrtc-capture-vi tegra-capture-vi: uncorr_err: request timed out after 2500 ms
[ 192.859930] tegra-camrtc-capture-vi tegra-capture-vi: err_rec: attempting to reset the capture channel
[ 192.860506] (NULL device *): vi_capture_control_message: NULL VI channel received
[ 192.860682] t194-nvcsi 13e10000.host1x:nvcsi@15a00000: csi5_stream_close: Error in closing stream_id=4, csi_port=4
[ 192.860915] (NULL device *): vi_capture_control_message: NULL VI channel received
[ 192.861109] t194-nvcsi 13e10000.host1x:nvcsi@15a00000: csi5_stream_open: VI channel not found for stream- 4 vc- 3
[ 192.861603] tegra-camrtc-capture-vi tegra-capture-vi: err_rec: successfully reset the capture channel

Looks like the communicate with TI933 failed.

Thank you for your help. Can you prompt me where I caused the problem?

Consult with HW to confirm the Power Down/Rest PINs status.

I checked the relevant hardware. Do you have any other valuable suggestions for me?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.