Animation Curve Keys not showing in simulation

I’m trying to create some animation curve keys programmatically via python. With the code below I can create them, but the prims don’t actually move when I start rendering with my custom writer. I know the keys exist, because they work when I open the scene with these keys in Isaac Sim with ./
So I thought, there were extensions missing in the standalone python script, but even by activating the Animation Timeline, Curve Editor and Sequencer extensions, I still can’t see the animations. There is also the error “Sequence Schema extension must be set to Autoload on startup” with enabling the omni.kit.sequencer.core and omni.kit.sequencer.usd extensions.
I tried this code with Isaac Sim 2022.2.1 and 2022.2.0:

manager =
manager.set_extension_enabled_immediate("omni.anim.timeline", True)
manager.set_extension_enabled_immediate("omni.kit.sequencer.core", True)
manager.set_extension_enabled_immediate("omni.kit.sequencer.usd", True)
                            value=Gf.Vec3d(0, 0, 0),
                            value=Gf.Vec3d(0, 0, 10),

Do you have any ideas for how to enable the autoload or making the animations work?

Hi @benedikt.schnoerr - Is there a reason you are using almost 1 year old version?

Hi, sorry for the late reply, I’m using 22.2.0 because the newer versions don’t really work for me.
I’m using a lot of .obj-Imports which cause an “Cannot determine file format” error in Isaac Sim 22.2.1.
And the 2023 versions don’t even start the simulation app with any python scripts with the error message "ModuleNotFoundError: No module named ‘omni.isaac’.
So, 22.2.0 is really the only version that works properly so far.

Hi @benedikt.schnoerr - Can you please share the configuration of your workstation/laptop?, are you able to open other latest OV apps through launcher?

Hi, yes, I’m using a laptop with Ubuntu 22.04, a Quadro RTX 3000 gpu, nvidia 535.113.01 drivers and cuda version 12.2. I tested my scripts also with other Ubuntu 22.04 based systems and similar drivers.
Also, Omniverse Code works in the latest version. Maybe the animation curve keys don’t work, because some extension isn’t activated in the python script. As I said, they work when I open Isaac Sim through the launcher or with ./
About the 2023 versions: Is there any difference in how to start the simulation app with python? This is, what I tried with 2023.1.1:

    "width": 1280,
    "height": 720,
    "sync_loads": True,
    "headless": False,
    "renderer": "RayTracedLighting",
    "num_frames": 10,
    "num_subframes": 10,
    "num_lights": 3,
    "amount": 1

from omni.isaac.kit import SimulationApp
sim = SimulationApp(launch_config=CONFIG)

And that’s the error message:

Traceback (most recent call last):
File “/home/developer/isaac_ws/rossmann_scripts_2/”, line 13, in
from omni.isaac.kit import SimulationApp
ModuleNotFoundError: No module named ‘omni.isaac’