ArduCam causing Jetson Nano to crash


I have a Jetson Nano B01 ( and I am trying to get an IMX477 camera ( to work. I am using the CSI Camera Script by Jetson Hacks (GitHub - JetsonHacksNano/CSI-Camera: Simple example of using a CSI-Camera (like the Raspberry Pi Version 2 camera) with the NVIDIA Jetson Developer Kit). Here is the script. (2.5 KB)
When I try to run it, the Jetson Nano crashes. It goes through the steps but then just stops and crashes. Here is the output.
output.txt (2.0 KB)
Please Help. Thank you.

hello arjunbhatia480,

there’s an error… nvbuf_utils: Could not get EGL display connection.
had you setup environment variable? please try $ export DISPLAY=:0 and then launch the nvarguscamerasrc pipeline again.

if that’s still not working, please check camera functionality with application using V4L2 IOCTL directly.
for example, $ v4l2-ctl -d /dev/video0 --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=100


I added the export DISPLAY=:0 and when I ran the script the Jetson Nano crashed immediately.

I tried using the v412-ctl command and nothing is happening. I ran the command and waited 10 minutes for something to happen and nothing happened.

please setup a terminal with $ dmesg --follow to monitor kernel messages, and running v4l standard IOCTL again for checking.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.