Assistance in Detecting IP address of Jetson AGX Xavier

Hello all,

I am using a windows host and I am using Ubuntu 18.04 through VirtualBox to download Jetpack and flash the Jetson AGX Xavier. I’ve successfully flashed the OS, but it seems as though I am having a difficult time at the last step where it is trying to determine the IP address of the target.

Primarily my host PC was connect to WiFi, while the Xavier was connected to the router. I keep getting an error the says, “JetPack is unable to determine the IP address of the Jetson Developer Kit”, followed by whether I would like to retry or manually enter my IP Address. Please find the image attached of the terminal error I receive about the IP.

I have also tried hardwiring my host pc to the router instead of WiFi and I am still getting the same same issue.

I noticed this person had a similar issue as I did, and it would solved by manually entering the IP address: JetPack 4.X Install with a VM (Solved)

I have attempted to find the IP address using “ifconfig” on my host computer and even looking at the connected devices through my internet’s phone app that shows the connected devices and their information. I have also tried turning on the Xavier to “ifconfig” to determine what the IP address is, but it just seemed to permanently be stuck at the NVIDIA logo.

Would someone be able to help? I’m about to dust off my old overheating Dell XPS 13 from the closet which I had Ubuntu 18.04 as the OS to see if maybe using a VM is the issue, but I don’t think that is likely the case.

I recently went through this process to flash my Jetson AGX Xavier Developer Kit from a MacBook using an Ubuntu 18.04 VM in Parallels. I used the NVIDIA SDK Manager: and when the AGX Xavier rebooted, it prompted me to setup a local user, pass and select a hardware performance profile. After that, I had the Ubuntu desktop on the AGX. I opened up a terminal from there and ran ifconfig to find the IP Address. The SDK Manager back on my Ubuntu VM wanted the user, pass (I just created) and IP Address. The SDK Manager was pre-populated with an IP that wasn’t even on the same subnet as the VM. After putting in the right details there, it proceeded to install the rest of the software.

It seems to me like you’re doing the right thing. Might be worth trying the NVIDIA SDK Manager before resorting to a non-virtualized Ubuntu.

  1. Officially we don’t support jetpack or sdkmanager over VM. If it can work, then we don’t guarantee the follow-up function would work fine or not.

  2. I am not sure where does this “Determining the IP address …” log come from. Haven’t seen such log since some old jetpack versions. What is the jetpack version here?

Also, you can configure the IP manually from UART or HDMI monitor.

I downloaded JetPack 4.1.1 from Downloads that supported the Jetson AGX Xavier. From the Downloads page, I filtered the downloads to the Jetson AGX Xavier and typed in Jetpack.

How would I configure the IP manually? The Xavier is stuck on the NVIDIA logo when I am connected to a monitor through HDMI.

Jetpack 4.1.1 is just a developer preview. I don’t suggest to use that anymore. Please move on to new software release.

Hi WayneWWW,

Thank you very much for all your help. I followed your instructions. I ended up dusting off my old Ubuntu OS laptop, and downloaded the newest version of NVIDIA SDK Manager and within an hour everything was working. Lesson learned: Use the actual OS rather than VM for faster and more pain-free results. You can mark this as resolved.

1 Like