Audio2Face does not start (Error-Message: Omniverse Kit is not working properly)

Hi there, I have an issue with the Audio2Face-App.
When I start it I get a message that the Omniverse Kit is not working propelry.
When I start “Create” or “Machinima Beta” everything works fine.

My specs:
OS: Windows 10 22H2
CPU: Intel(R) Core™ i7-9800X CPU @ 3.80GHz
CPU Cores: 8
Storage: 2TB SSD with 1.5TB free
GPU: RTX3090Ti
GPU Driver-Version: 522.25

Omniverse App Versions:
Nucleus Navigator Version: 3.2.0
Drive Version: 100.1.11
Create Version: 2022.2.2
Machinima Beta Version: 2022.2.1
Audio2Face Version: 2022.1.2

Do you have the log?

Also try clearing kit’s cache folder and see if it helps C:\Users\username\AppData\Local\ov\cache\Kit

Here are the logs from …/.nvidia-omniverse/logs/Kit/Audio2Face/2022.1
kit_20221027_094312.log (444.2 KB)

Clearing the cache did not help.

I don’t see any warning or error in the log that shows anything suspicious.
Is this the first time you started A2F? or previous version was working before.

Try go to your ov lib folder shown in our Launcher Settings and find the Audio2face folder you installed

Are you able to run the audio2face.kit.bat file by double clicking it?

Hi there,
so I looked for the lib folder, in my case there is none, the folder that is shown is called “pkg”.
When I go into this folder and in the audio2face-2022.1.2 I only have a “audio2face.kit” without the “.bat”.
When I start it, it opens up the same Window that opens when starting it from the omniverse launcher.
But here the same problem shows up.

And for the other question:
It is like this since I tried to start it the first time.
But I allready deinstalled and reinstalled all of the NVIDIA Omniverse, but this did not help.

Hi @william.menz ,
The .kit file is not executable. so if you are able to run it, it’s probably a .bat file with the extension of the file hidden in your browser.
One other thing to try, is in the folder where you file the audio2face.kit file, you should see there’s a kit folder.
In the kit folder, there’s, can you try run that? I assume this one would run fine (but without a2f)
It also helps if you can try run the previous .bat file in terminal, as sometimes there could be other error log on the terminal that you might be able to share here as your previous .log file doesn’t contain much error info

@esusantolim starting the was possible, when I started it in the terminal.
It took a while to load, but after that everything worked out.
So does this give any information on why the Audio2Face is not working?

@william.menz , if the kit coming with A2F runs fine for you, then it’s suggesting that something with A2F extensions is not loading properly.
Can you try running the audio2face.kit.bat in terminal and share the error message, please?

This would be the messages that I get when I start from the cmd:

And here would be the log-file of the attempt to start it:
kit_20221108_110346.log (444.3 KB)

Hi @william.menz ,
We apologize for the issue. The log doesn’t show anything out ordinary. no errors or such…
One thing we can try is to disable the audio2face.wizard extension which is the one used for loading the default scene on app start up.

Here are the steps:

  1. in the folder where you find audio2face.kit.bat, you should see there’s apps folder that contains a few .kit files. Mine looks like this
  2. Open the audio2face.kit file using text editor.
  3. comment out line 50 and 315 by adding # at the start of the line like this:
  4. Save this file
  5. try launch audio2face again.

Thanks for the help.
Sadly i need to tell you, that commenting out the lines did not help with my problem.
First I commented the two lines out in the audio2face.kit in the folder you told me. Than I started the application useing the command window. Same problem as before.
After that I tired commenting the lines out in the audio2face.full.kit but nothing changed.
So I will put the lines back in again, that I dont forget it later on :D

I will try downloading the application on a different machine and see if it works there.
But it is still a bit weird considering the logs…

If someone still has any ideas, kindly let me know.