Audio2face not launching here as well..though all other Omniverse apps working fine

Launching the latest Omniverse audio2face (all drivers current and I switched between game and studio with no different results) results in exception errors. Ran “scannow” in Windows 10 and it found and fixed a file or two. Reloaded A2face and still no joy. Driver is the latest studio version.


Unknown software exception 0x40000015 occurred in the application at location 0x000000006f7ed3e2. Click on OK to terminate program.

Command prompt readout from running manually:

[Info] [carb] Initializing plugin: (interfaces: [carb::events::IEvents v0.2]) (impl:
[0.182s] Loading user config located at: ‘D:/Video Production/Kit/Audio2Face/2021.2/user.config.json’
[0.342s] [ext: omni.assets.plugins-0.0.0] startup
[0.346s] [ext: omni.kit.window.splash-0.0.0] startup
[0.389s] [ext: omni.kit.async_engine-0.0.0] startup
[0.396s] [ext: omni.kit.agent-0.1.0] startup
[0.399s] [ext: omni.kit.splash-0.1.0] startup
[0.411s] [ext: omni.usd.config-1.0.0] startup
[0.414s] [ext: omni.usd.libs-1.0.0] startup
[0.656s] [ext: omni.kit.pipapi-0.0.0] startup
[0.663s] [ext: omni.usd.schema.semantics-0.0.0] startup
[0.670s] [ext:] startup
[0.677s] [ext: omni.hydra.iray-0.1.0] startup
[0.684s] [ext: omni.kit.pip_archive-0.0.0] startup
[0.696s] [ext: omni.kit.loop-default-0.1.0] startup
[0.697s] [ext: omni.stats-0.0.0] startup
[0.702s] [ext: omni.client-0.1.0] startup
[0.719s] [ext: omni.appwindow-1.0.0] startup
[0.939s] [ext: omni.kit.test-0.0.0] startup
[0.957s] [ext: omni.kit.renderer.core-0.0.0] startup

| Driver Version: 471.11 | Graphics API: D3D12
| GPU | Name | Active | LDA | GPU Memory | Vendor-ID | LUID |
| | | | | | Device-ID | UUID |
| 0 | NVIDIA GeForce RTX 2070 SUPER | Yes | | 8011 MB | 10de | 1241c000… |
| | | | | | 1e84 | 0 |
| OS: Windows, Version: 10.0 (20H2), Build: 19042
| Processor: AMD Ryzen 9 3900X 12-Core Processor | Cores: 12 | Logical: 24
| Total Memory (MB): 32714 | Free Memory: 21663
| Total Page/Swap (MB): 64458 | Free Page/Swap: 45799
[2.457s] [ext: omni.ui-2.1.4] startup
[2.480s] [ext: omni.kit.mainwindow-0.0.0] startup
[2.488s] [ext: omni.kit.uiapp-0.0.0] startup
[2.489s] [ext: omni.usd.schema.anim-0.0.0] startup
[2.508s] [ext: omni.usd.schema.physics-0.0.0] startup
[2.519s] [ext: omni.hydra.scene_delegate-0.1.0] startup
[2.528s] [ext: omni.kit.commands-0.0.0] startup
[2.539s] [ext:] startup
[2.542s] [ext: omni.timeline-1.0.0] startup
[2.549s] [ext: omni.usd-1.3.0] startup
[2.644s] [ext:] startup
[2.662s] [ext: omni.kit.material.library-1.0.4] startup
[2.676s] [ext: omni.kit.stage_templates-1.0.3] startup
[2.686s] [ext:] startup
[2.695s] [ext: omni.graph.core-1.0.0] startup
[2.700s] [ext:] startup
[2.718s] [ext: omni.kit.context_menu-1.1.0] startup
[2.824s] [ext: omni.graph-1.0.0] startup
[2.871s] [ext: omni.hydra.rtx-0.1.0] startup
[2.876s] [ext: omni.renderer-rtx-0.0.0] startup
[2.878s] [ext: omni.anim.shared-101.0.5] startup
[3.005s] [ext: omni.kit.window.viewport-0.0.0] startup
2021-07-20 03:31:01 [3,923ms] [Warning] [carb.settings.plugin] getSharedArray: supplied array buffer doesn’t fit the requested array
[4.079s] [ext: omni.kit.usd_undo-0.1.0] startup
[4.088s] [ext: omni.kit.viewportDraw-2.0.0] startup
[4.099s] [ext: omni.anim.deltaBlend-101.0.7] startup
[4.110s] [ext: omni.kit.mesh.raycast-0.1.4] startup
2021-07-20 03:31:01 [3,971ms] [Warning] [omni.ext.plugin] [ext: omni.kit.mesh.raycast-0.1.4] extension.toml: [[native.plugins]] is deprecated, please rename to [[native.plugin]] (no ‘s’ letter)
2021-07-20 03:31:01 [3,973ms] [Warning] [omni.ext.plugin] [ext: omni.kit.mesh.raycast-0.1.4] extension.toml: [[python.modules]] is deprecated, please rename to [[python.module]] (no ‘s’ letter)
[4.124s] [ext: omni.anim.wrap-101.0.7] startup
[4.135s] [ext: omni.anim.deltaMush-101.6.3] startup
[4.150s] [ext: omni.kit.charTransfer-1.3.1] startup
[4.278s] [ext: omni.kit.renderer.capture-0.0.0] startup
[4.292s] [ext:] startup
[4.300s] [ext: omni.kit.thumbnails.usd-0.3.0] startup
[4.350s] [ext:] startup
[4.469s] [ext: omni.kit.search_core-1.0.0] startup
[4.481s] [ext: omni.kit.widget.path_field-2.0.1] startup
[4.494s] [ext:] startup
[4.504s] [ext: omni.kit.widget.settings-1.0.0] startup
[4.516s] [ext: omni.kit.widget.filebrowser-2.2.0] startup
[4.538s] [ext: omni.kit.widget.browser_bar-2.0.1] startup
[4.552s] [ext:] startup
[4.587s] [ext:] startup
[4.596s] [ext: omni.kit.window.popup_dialog-1.0.1] startup
[4.611s] [ext: omni.kit.widget.prompt-1.0.0] startup
[4.624s] [ext: omni.kit.window.filepicker-2.2.0] startup
[4.693s] [ext:] startup
[5.199s] [ext:] startup
[5.332s] [ext: omni.kit.widget.stage-2.4.0] startup
[5.352s] [ext: omni.rtx.window.settings-0.6.0] startup
[5.370s] [ext: omni.kit.window.file-1.2.0] startup
[5.474s] [ext: omni.kit.thumbnails.images-0.1.0] startup
[5.489s] [ext: omni.videoencoding-0.0.0] startup
[5.495s] [ext: omni.rtx.settings.core-0.5.4] startup
[5.510s] [ext:] startup
[5.527s] [ext: omni.kit.window.content_browser-2.1.3] startup
[5.607s] [ext: omni.audio2face.core_deps-0.1.0] startup
[5.632s] [ext: omni.kit.capture-0.3.4] startup
[5.650s] [ext: omni.audio2face.player_deps-0.1.1] startup
[5.673s] [ext: omni.kit.window.movie_maker-0.4.2] startup
[5.693s] [ext:] startup
[5.737s] [ext: omni.audio2face.core-0.1.1] startup
A s s e r t i o n f a i l e d !

P r o g r a m : D : \ V i d e o P r o d u c t i o n \ a u d i o 2 f a c e - 2 0 2 1 . 2 . 5 \ k i t \ k i t . e x e
F i l e : s r c / h o s t a p i / w d m k s / p a _ w i n _ w d m k s . c , L i n e 1 0 8 1

E x p r e s s i o n : F A L S E
2021-07-20 03:31:21 [23,606ms] [Error] [carb.input.plugin] Subscriber 7 not found

My Hardware:

OS Name Microsoft Windows 10 Home
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer Gigabyte Technology Co., Ltd.
System Model X570 AORUS MASTER
System Type x64-based PC
System SKU Default string
Processor AMD Ryzen 9 3900X 12-Core Processor, 3800 Mhz, 12 Core(s), 24 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F11, 12/6/2019
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product X570 AORUS MASTER
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = 10.0.19041.1110
User Name DESKTOP-7KEKG1R\default
Time Zone Eastern Daylight Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 21.6 GB
Total Virtual Memory 62.9 GB
Available Virtual Memory 45.3 GB
Page File Space 31.0 GB
Page File E:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Thanks for testing out Audio2Face and the information you provided.

From the info you gave, everything looks fine on the HW and driver side. It looks like the windows version is outdated "10.0.19042 Build 19042
We support Windows10 version 1909+

Just to double check, can you try one more thing. Can you click on the windows button and type “winver” and post a screenshot of what you see there to confirm?

Much appreciate it. Thanks.

Other than Windows version, I also see you have an Assertion Error. You can also look at the FAQ here for how to get around this issue. Plus other information.

Thank you for your reply Siyuen. I reviewed all Assertion Error info and found only one of its kind that addressed a sound issue regarding “leaked contents” on line 1061. However my Assertion Error is on line 1081 and refers to “Subscriber 7 not found.”

I checked the WINVER information on Windows 10 as you suggested and was not aware Microsoft was not upgrading its builds. You are correct, my build shows as Windows 10 19042. I refreshed my updates but see no newer build offered. I ran the Windows assistant and it gave me this information instead. It states: “This PC is running version 20H2”. I see that the build and version are not the same thing. I do not understand how to get a newer version because when I attempt to ask microsoft to upgrade they tell me i have the latest version.

Ok looks like you are running the latest version. The screenshot from winver I am looking for is like this


Does seem like 19042 is one of the latest (post 1909) so that should be good. We have not run into this issue before so have to take a closer look. do you mind sending us the full log located here:

Just also curious, what kind of sound device do you have? Any external sound cards? Also are you running a non-English Windows version?

Understood. Omniverse log info:
launcher.log (624.5 KB)

Sound card is the onboard Realtek on the Aorus Master 570X motherboard. Standard English Win 10. Update Assistant allows 21h1 update now and so I began that after you mentioned I was behind :) I was holding off till they resolved the sound issues 21H1 update sometimes has. It say I am 87% there.

Got it thank you. We will have a look and let you know.

Could you post your audio2face log as well? It should be somewhere like “C:\Users\%user%\.nvidia-omniverse\logs\Kit\Audio2Face\2021.2”. You can also check the logs location from the launcher settings window.

Understood. Here are the A2face logs:

kit_20210719_223752.log (119.2 KB)
kit_20210711_164447.log (118.8 KB)
kit_20210701_183405.log (118.6 KB)
kit_20210719_232011.log (117.8 KB)
kit_20210719_224415.log (117.7 KB)
kit_20210719_233057.log (117.7 KB)
kit_20210719_232155.log (117.7 KB)
kit_20210719_231736.log (117.7 KB)
kit_20210719_224208.log (117.6 KB)
kit_20210719_225159.log (117.6 KB)
kit_20210719_225714.log (117.5 KB)

Hi @camworksfilm,
Thank you for all the log files.
We didn’t see any error that would have caused the app to crash, so most likely the log failed to catch that.
I’m wondering if you are able to run other Omniverse app (like Create) before?
One other thing if you can help us test is to run the kit.exe file directly.
from the logs, yours would be here:
D:/Video Production/audio2face-2021.2.5/kit/kit.exe

This would run Kit as it is without any a2f extensions.

Create and Machinima all work fine.

You were correct, I attempted the kit.exe approach w/o extensions and it booted up the program successfully. Just so you know I had deleted A2face and did a fresh install in case it was corrupted. There was no change. The full program still will not boot up.

Only possible flag I noticed was in yellow while booting in verbose mode:

Hi @camworksfilm ,
Thank you for your patience. I’m asking around here internally to see if there’s anyway we can troubleshoot the issue better. Please bear with us a bit logner.

Thank you. I appreciate the effort. I understand from my brother, that our main computer over at Real Game FX is able to run it fine. Unfortunately that is a half a state away from me and its hardware is not much different than mine except for a stronger RTX card. We are very interested in seeing the capabilities demonstrated in some projects we are contemplating.
Thank you

P.S. I still do not understand the “Subscriber 7 not found” error?

Hi @camworksfilm Most probably you are having issues with PortAudio library (that ASSERT message). Could you please try the solution from the FAQ, related to that. Even though the assertion line there is 1061 versus your 1081, the issue could be similar.

I have same problem with ryzen 5900x + 5950 and 3090.i cant lunch .please help me

Hi @phuonglk0975 , can you please send in your logs also? Are you getting the same Assertion Error? If so pls try the suggestion Dmitry mention and see if that helps. Thanks

kit_20210727_073228.log (116.9 KB)
yeah. you can fix soon i need build the sence with audio2face

Thank you Dmitry,

I will give the solution a try and get back to you. However, I did forget something…

For emergencies I keep a clean fresh Windows 10 installed on my computer on another NVME drive just in case. I decided I would load Omniverse onto the drive and run A2Face there. To my surprise it ran perfectly. Same computer and no hardware changes or adjustments.

I will make my PortAudio adjustments now that I am went back to my original home drive and post the results.

Thanks again.

1 Like

The solution was:

Replacing the libportaudio64bit.dll files in both the A2Face core and player deps. (I used Everything from Voidtools to save alot of hunting for the .dll files since my files were not C drive. Syntax searched ALL drives and directories instantly…made Microsoft file search look silly: )




With the file\portaudio-r1891-build\lib\x64\Release\portaudio_x64.dll (Rename this file to “libportaudio64bit.dll”) in this zip file:

With the file\portaudio-r1891-build\lib\x64\Release\portaudio_x64.dll (Rename this file to “libportaudio64bit.dll”) in this zip file:

Thank you Team!!!
Lance from CamWorks Films

1 Like

@camworksfilm - sounds like the portaudio issue is the problem then, so everything working now?

We will continue to look at this issue as so far it has happen to users but is bit random on which machine it happens to and we have not been able to replicate internally. We will try to get improve this.