Audio2Face Riva Integration setting error

Hi, I watched this demo video for Audio2Face and NVIDIA Riva Integration.

And I tried to set but failed, with error message:

"InactiveRpc Error of RPC that terminated with:"

And I tested RIVA server (50051) port which was functional.

Hi @czhang1! I wanted to let you know that I contacted the Audio2Face team to help with your problem. It might help them troubleshoot the error if you could attach your logs. You can find them here:
C:\Users<USERNAME>.nvidia-omniverse\logs\Kit\Audio2Face.

Hi @czhang1 , thank you for using Audio2Face!

  1. You shouldn’t have the same combination of “host:port” for both Riva and A2F Streaming player (localhost:50051 in your case). There will be a port conflict. Most probably either Riva or A2F player was automatically switched to another port or crashed. Since 50051 is hardcoded for A2F player at the moment, try chaining Riva port manually to something else.
  2. If nothing of this helps, please provide the full log file, as Wendy mentioned.

Thanks, I guess you are the speaker of the video I post. I tried to set RIVA port as 50050, and left 50051 for A2F.

But i don’t know how to setup ‘audio streaming player instance’, or it is enabled by default ?

If you are using a pre-configured demo scene (“Streaming Demo Scene”), yes, the instance is already there. If you want to know more about streaming audio player, check out this video: Overview of Streaming Audio Player in Omniverse Audio2Face - YouTube
Did changing the port help?
If not and you are still getting errors, please provide the full log file.

done, thanks Dmitry.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.