Auvidea J120 with TX2

Hi, Now I’m trying to set up the TX2 with Auvidea J120 Carrier board.

However, It is really struggle to make properly work USB both 2.0 and 3.0.

Actually, I’ve already look in

https://devtalk.nvidia.com/default/topic/1018849/jetson-tx2/auvidea-j120-for-tx2-compatibility-limitations/

this discussion, however it’s still hard to catch up.

Now I’m using TX1 with J120 board and there was a installation guide so it is easy to set up however in this case is not.

The error message is like that.

include/linux/platform/tegra/gegra_mc/h:77:10: error: ‘ENODEV’ undeclared (first use in this function)
return -ENODEV;

Thank you.

Hi SG_HUB

Are you using their latest J120 firmware, and USB3.0 patch?
See https://auvidea.com/firmware/

It issue also discussed at https://devtalk.nvidia.com/default/topic/1023051/jetson-tx2/auvidea-jetson-tx2-usb3-0-problem/

Hi kayccc

Yes, I’m using the latest firmware

But I’m still don’t know THE HOW TO.

I cannot understand what snarky said at https://devtalk.nvidia.com/default/topic/1023051/jetson-tx2/auvidea-jetson-tx2-usb3-0-problem/

“You are forgetting the O=… and ARCH=… options to the make call. Those are needed.”

Could you help me to do it?

Just a bit of arcane knowledge on compile of a kernel: The “O=/some/file/path” is used when building a kernel with temporary files and output in an alternate location. Normally this would be optional, but some changes were made in R28.1 kernel source layout when both the TX1 and TX2 started using the same source. The R28.1 documentation under kernel customization explains which must be used. See (search for “Documentation”):
https://developer.nvidia.com/embedded/linux-tegra