bcm2385-v4l2 not found

modprobe: FATAL: Module bcm2385-v4l2 not found in directory /lib/modules/4.9.140-tegra

Console keeps printing out this line and even system. This does not allow me to run the x2go server which i need to use for my jetson-tx2 project.

Things i have tried:

sudo modprobe bcm2385-v4l2

grep “bcm2835-v4l2” /etc/modules || echo “bcm2835-v4l2” >> /lib/modules

uninstalling and installing v4lt tools


What’s bcm2835?
I believe the original kernel Image didn’t include this module you need to add this driver by yourself.

thing is, the day before everything was working fine but after a reboot it started showing this error every time i boot up and every time i brought up the terminal. hell it even screwed with all my services where i had no gui interface and was forced to ssh and startx.

Does reflash the tegra to original image work again?

Will have to resort to that today. Was just trying to avoid setting it up again but it ended up taking more time anyways.

Did you update your customize kernel Image?

I have the same problem, that my raspberry camera v2 suddenly doesn’t work. I flashed once the os and the camera worked normally, now after updating today the camera stopped working. What gives?

Hi bubanja.kaju,

Please open a new topic for this issue. Thanks