Begin Post Wrap Error

Hello, I am testing with a mesh and it gives me the following error.

Warning: inputs FaceVertexInderex empty on mush

In the video you can see the complete error.
Any ideas?
Thanks

Hi @antoni.caimari.caldes,
Thank you for tryingout Audio2Face.

This warning is usually safe to ignore, it happens when the OmniGraph node is created but not yet initiated with connected with any data/connection, but it should go away on the next update tick.
In your case, is your mesh appeared back? Try check if there’s any mesh in the same hierarchy as your target mesh with the “_result” postfix listed in the Stage view.

2 Likes

Dear @esusantolim there is indeed a head result. But I can’t find it on the screen, neither above, nor below, etc.
Still trying to continue with the process and adding a “+ A2f Pipeline” gives the same error and nothing is added in the panel.
The warnings do not stop, they are continuous, like a loop.
I attach an image.

Ah okay.
This is probably due to different issue.
Currently we are not supporting mesh with subGeom material assignment (on omnigraph deformed mesh). This is something the team is aware of and have internal ticket assigned to fix.
Can you try deleting all those subsets under your original geo and try run the mesh fitting and postwrap again? See if you got anything back.
If that doesn’t work, I would need to take a closer look at your scene. Would you be able to share your scene if the above suggestion doesn’t work?

Dear @esusantolim these past fias I have been doing tests.
I have deleted all the subsets as you have recommended, but I have not yet managed to go to the final stage.

Here are 2 projects so you can locate the errors.

The first is a head imported from a fbx

The second is a head imported from an obj

Each of them has different behaviors.
See if you can discover something.

In the folder you have the 2 projects and the head in fbx and obj;

I also attach some images of different errors;


This image is with the import of the head in FBX and it never exceeds the begin mesh, it always stays at 37%


This image is with the import of the head in OBJ and passes the fitting and the post wrap, resulting in a head_result, but the “Bulding TensorRT engine” never syncs.

Thank you @antoni.caimari.caldes for the files.
I’ll take a look and try repro the issue on my side.
Will let you know what I find. Stay tuned.

1 Like

Also just curious, Are you able to get Mark’s face itself working (The one that is loaded by default when you start the app).
We also supply 2 example character transfer setups (Alien and Allison). Are you able to open those and test A2F with those?
Cheers,
edy

1 Like

I’m able to repro this bug. What happens here is on this mesh, the mesh contains points that are not connected anywhere.


Both FBX and Obj file seems to contain the same mesh. Opening this file in maya (in the image above), you can see that the highlighted points 4212 vs total points 21556.
This issue was reported internally recently and fixed, but it would have to wait for another patch release cycle after 2021.2.5 patch which is already on the way. Please bear with us…
I also noticed that this head mesh still contains eyeball mesh being merged to the head mesh. This is not recommended.
Meanwhile, I suggest suggest take the mesh to other 3D authoring app (like Maya or Blender), and run the mesh separation there. In Maya, Mesh>Separate menu should do the job of separating out the eyeball meshes and remove the disconnected points.

Regarding the other issue with “Bulding TensorRT engine” never syncs. Please let me know if the default scene & the example scene works for you.

Thank you, if I have tried with Alison and the Alien before and it works correctly. Mark always works :)

1 Like

Thank you for your work. How wonderful that with the new patch, the program fixes mesh errors.
I will do what you recommend. I’m going to clean the disconnected points and separate the eyes.
Regarding the Bulding TensorRT, if it works with marc and the example figures.
I will continue with the tests.
Thanks for the great guidance.

1 Like