Post Wrap deforms and scales mesh

I get a decent fitted mesh from the “Skin Mesh Fitting”.

With that mesh, at the Post Wrap step and regardless of Smooth Level, my original mesh gets distorted, stretched and scaled.

It can be linked and it works, but the scale and proportions are off. What could be the issue?


Hello @dmtzcain! I’ve asked for some assistance from the dev team. I will post back as soon as I have more information for you!

Thanks for reporting @dmtzcain
Do you have transform on your character mesh previously? Are you able to share the scene for us to investigate further? (You can send through DM if it’s not meant to be shared with public)

Hi, Sent you more files privately, but here is the file with the original bug.

Let me know your thoughts.
TestVoiceToMesh.usdc (32.4 MB)


Hi @dmtzcain,
I tried opening your scene with Audio2face 2022.1.2
then apply postwrap, then apply A2F core to grey Mark, and it seems to be working fine.
If the issue persist on your end, Can you try deleting your close your app, delete your user config, and start the app again?

Your user config file can be found from the Data Path on the Launcher Settings,
find the data path:

under the data folder, find Kit/Audio2Face/2022.1/user.config.json

Delete that file, and start the app again.

Thank you,
Somehow I attempted again with the files and it worked. Not sure what changed but I’ll re configure the app again.



I am having a similar issue to this. I have tried deleting the user.config which hasnt fixed it.
Here is a screenshot of the error which pops up druing the post wrap process then goes away:

Any help would be appreciated,


1 Like

i have the same issue, with the same error messages.
I tried audio2face at first on another PC. Everything went smooth. But as i switched to my main Setup i cant pass the post wrap step.
Help would be apreciated! Thx

Hey Folks,

I figured out, that the issue wont appear on an earlier release of the app. If i am post wraping the exact same file in 2022.1.1 there is no issue. hope that helps as a quick fix :)

but @ the thechsup and devs:
would love to know whats the problem, so i could use the latest releases. Thx


exact same issue here. Been going absolutely crazy all day with it.

The thing is, it seems that files made with earlier versions work in this version when you simply run it (aka the samples) but a fresh scene will ALWAYS result in this exact same warping. its driving me mad

New post wrap - no dice. This is after deleting the user config as mentioned.

I dont know what u are using for the export, but i switched today to the blender USD Branch, and everything is so much easier now. Or lets say: its complicated on different ways haha, but at least i got some export options, and the model comes fully textured into a2f.

Can you share your scene file, please?
I’m pretty sure it’s something simple like some extra xformOp we didn’t account for.

Solution: The bug is gone for me. What I did differently is un-parent the existing armature of my character, then make sure that all transforms are applied and that the head is at a human scale in cm.

Have not experienced the stretching since.

1 Like

@dmtzcain , the Character Setup is supposed to make a copy of your target geo at it’s world transform, at that point in theory it doesn’t matter where it’s previously parented anymore.
I’d love to see and replicate this issue if you are willing to share your file for me to repro the issue.
My email is

I can’t seem to repro this still…
Looking at the error messages you have, it looks like the postwrap process stopped when trying to do Warp operations.
We will add an option to switch off Warp on the next release.