Black screen after instalation drivers rtx3070 kali

Hello,

After update, upgrade and installing correct headers, ive installed nvidia driver and nvidia-cuda-toolkit. During instalation i had message that default gpu drivers will be disabled after reboot.

After reboot i got blinking lop-left cursor and then BLACK SCREEN appears. Cant do anything.
Ive entered recovery mode and there everything works fine. Gui is enabled and drivers are installed fine.

lspci -s 29:00.0 -v
29:00.0 VGA compatible controller: NVIDIA Corporation GA104 [GeForce RTX 3070] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Micro-Star International Co., Ltd. [MSI] GA104 [GeForce RTX 3070]
        Flags: bus master, fast devsel, latency 0, IRQ 94, IOMMU group 16
        Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 7fe0000000 (64-bit, prefetchable) [size=256M]
        Memory at 7ff0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at fc000000 [virtual] [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nvidia
nvidia-smi          
Thu Feb 29 21:03:06 2024       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 525.147.05   Driver Version: 525.147.05   CUDA Version: 12.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:29:00.0  On |                  N/A |
|  0%   39C    P3    35W / 280W |   1051MiB /  8192MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      1016      G   /usr/lib/xorg/Xorg                897MiB |
|    0   N/A  N/A      1288      G   xfwm4                               4MiB |
|    0   N/A  N/A      1864      G   ...b/firefox-esr/firefox-esr      146MiB |
+-----------------------------------------------------------------------------+

I tried to delete xorg.conf like many tutorials said, but that file is missing.

[/etc/X11]
└─$ ls                 
Xreset    Xresources  Xsession.d        XvMCConfig       app-defaults             fonts    xinit  xorg.conf.d
Xreset.d  Xsession    Xsession.options  Xwrapper.config  default-display-manager  rgb.txt  xkb    xsm

nvidia-bug-report.log (1.3 MB)

There isn’t anything visible in the logs from the failed boot. Please boot to black screen, then reboot into recovery and run
sudo journalctl -b-1 >blackscreen.txt
and attach that.

Thanks for reply, there u go another log.

blackscreen.txt (130.3 KB)

That’s odd, no errors in the log, Xorg is just plain freezing after loading the vesa driver.
Only difference I can think of would be plymouth, please try removing “splash” from kernel cmdline. Please also try adding “nvidia-drm.modeset=1” to it.

for now its

GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

should i try to change DEFAULT or next line with param nvidia-drm.modeset=1?

Just add it to DEFAULT.

Still blackscreen. Uploading new log.
blackscreen2.txt (129.4 KB)

The kernel parameters didn’t change. Did you forget to run sudo update-grub?

Thats odd, i didnt forget about update-grub.
Maybe there is some conflict with other systems grub that i got installed.
After instalation of kali i fixed grub in ubuntu by ‘boot-repair’, then kali started fine till i installed nvidia drivers.

Ok i fixed it. Just like @generix said, there was no updated grub. I mean i changed manualy params to ‘nvidia-drm.modeset=1’ just before boot on normal mode by pressing ‘e’. Then boot was fine.
But that was temporary solution, like no one wants to do it everytime, right?
Ubuntu was my main OS, so i tried to update-grub there bcs it didnt worked on Kali.
Then Kali started to boot correctly.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.